summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-03-01 08:10:27 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-01 08:58:34 -0500
commit80e9cccfa6bf0f6fc15dda9f1423d5cdca8b2354 (patch)
treef11c4d54dfc5b575d1deef61193846099e121760 /app-eselect/eselect-php
parentdev-lang/php: new revisions that install the "phar" executable (diff)
downloadgentoo-80e9cccfa6bf0f6fc15dda9f1423d5cdca8b2354.tar.gz
gentoo-80e9cccfa6bf0f6fc15dda9f1423d5cdca8b2354.tar.bz2
gentoo-80e9cccfa6bf0f6fc15dda9f1423d5cdca8b2354.zip
app-eselect/eselect-php: new version 0.9.6.
New EAPI=7 version with some nice stuff: * The php-fpm-launcher script and php-fpm.conf tmpfiles.d entry are now upstream, simplifying the ebuild. * We install a logrotate script for php-fpm. * The eselect module itself now supports $ROOT. * We support symlinks for the "phar" executable. Closes: https://bugs.gentoo.org/692194 Closes: https://bugs.gentoo.org/709422 Closes: https://bugs.gentoo.org/707876 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-php')
-rw-r--r--app-eselect/eselect-php/Manifest1
-rw-r--r--app-eselect/eselect-php/eselect-php-0.9.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-eselect/eselect-php/Manifest b/app-eselect/eselect-php/Manifest
index 98e3dcbe5c97..9ede973795a3 100644
--- a/app-eselect/eselect-php/Manifest
+++ b/app-eselect/eselect-php/Manifest
@@ -1,2 +1,3 @@
DIST eselect-php-0.9.4.tar.xz 49576 BLAKE2B 417956b355ffec7d7cda03dffa94e4d749a2b33a64a216c2ed8492181a5385f5219078efe6cc4d0d2d81b0fac40901c0cf07914a826484b83833542a12b47359 SHA512 2ba1dd75d4bb9611c6687ed4449f715728263538f772652aa1ac013103cf9ddf328c854326cf6da4f9b3ff2279bf99d973325520fe8b4e3ba7a76a9c3264e78e
DIST eselect-php-0.9.5.tar.xz 49732 BLAKE2B 78c2010abcb1c9efd4d5f2f3f934365b338901a98bc8528131f2b9f564c1c3f740ab2dc2a28a0a58912e750062e61f75a7c6611c2f37019ca6525d729ffb5fd2 SHA512 55e401cb0c3ed19fed90485d62ba3deed3355503542898ff0d1b5404bd5fafb2f887df433609d4d4b28f32c0034100ea32c9e58547ef6417ea0b0f60d061d119
+DIST eselect-php-0.9.6.tar.xz 53236 BLAKE2B 38478d4792f8a527e5f519abd7765211aff8c1d132ceeba5eec70ea3b8d1f254be52564334fed3840950c2461ff4a30784b92fbb8b21cc448083617797eab1d4 SHA512 d3f14288b3493cb48717c1f27430ae8b60881e9f6f48e4b7644a4596d9fc1b9823a6af8b7101a62b28a92e3bff164b1717617a2642a5bb02e8dd46de56d4f410
diff --git a/app-eselect/eselect-php/eselect-php-0.9.6.ebuild b/app-eselect/eselect-php/eselect-php-0.9.6.ebuild
new file mode 100644
index 000000000000..42267cb5ce74
--- /dev/null
+++ b/app-eselect/eselect-php/eselect-php-0.9.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
+SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+ apache2? ( www-servers/apache[apache2_modules_dir] )"
+
+src_configure() {
+ # We expect localstatedir to be "var"ish, not "var/lib"ish, because
+ # that's what PHP upstream expects. See for example the FPM
+ # configuration where they put logs in @localstatedir@/log.
+ #
+ # The libdir is passed explicitly in case the /usr/lib symlink
+ # is not present (bug 624528).
+ econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --localstatedir="${EPREFIX}/var" \
+ --with-piddir="${EPREFIX}/run" \
+ $(use_enable apache2) \
+ $(use_enable fpm)
+}