summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-12-11 08:20:14 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-12-11 08:22:45 -0500
commitb10b08bc98169e5462fcdb82ab41640e5715f202 (patch)
tree28ad934f417715752bc610eba0efab134e5cf49f /app-eselect/eselect-php
parentapp-eselect/eselect-php: drop sys-apps/gentoo-functions dependency. (diff)
downloadgentoo-b10b08bc98169e5462fcdb82ab41640e5715f202.tar.gz
gentoo-b10b08bc98169e5462fcdb82ab41640e5715f202.tar.bz2
gentoo-b10b08bc98169e5462fcdb82ab41640e5715f202.zip
app-eselect/eselect-php: drop the "PHP5" backwards-compatibility shim.
A backwards-compatibility shim was added on 2016-01-05, in commit 1ae81f5, to prevent (unmodified) configurations from breaking when upgrading eselect-php. A "you should upgrade your configuration" warning was added three days later in commit 470b42d. I think two years is a long enough time to maintain the shim/warning, so this commit removes them from the live ebuild and latest revision. Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-eselect/eselect-php')
-rw-r--r--app-eselect/eselect-php/eselect-php-0.9.4-r5.ebuild (renamed from app-eselect/eselect-php/eselect-php-0.9.4-r4.ebuild)22
-rw-r--r--app-eselect/eselect-php/eselect-php-9999.ebuild22
2 files changed, 0 insertions, 44 deletions
diff --git a/app-eselect/eselect-php/eselect-php-0.9.4-r4.ebuild b/app-eselect/eselect-php/eselect-php-0.9.4-r5.ebuild
index 64684077116..c99ebdbb421 100644
--- a/app-eselect/eselect-php/eselect-php-0.9.4-r4.ebuild
+++ b/app-eselect/eselect-php/eselect-php-0.9.4-r5.ebuild
@@ -35,12 +35,6 @@ src_configure(){
src_install() {
default
- # This can be removed after a while...
- if use apache2 ; then
- insinto /etc/apache2/modules.d
- newins "${FILESDIR}/70_mod_php5.backcompat.conf" 70_mod_php5.conf
- fi
-
if use fpm ; then
systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
sed -e "s,@libdir@,$(get_libdir),g" "${FILESDIR}/php-fpm-launcher-r3" > "${T}"/php-fpm-launcher || die
@@ -48,19 +42,3 @@ src_install() {
doexe "${T}"/php-fpm-launcher
fi
}
-
-pkg_postinst() {
- if use apache2 ; then
- elog
- elog "If you are upgrading, be warned that our mod_php configuration"
- elog "file has changed! You should now define -DPHP for the apache2"
- elog "daemon, and inspect the new 70_mod_php.conf which has been"
- elog "installed. Module loading involves eselect as of this version."
- elog
- elog "You must run eselect at least once to choose your apache2 target"
- elog "before the new configuration will work. Afterwards, and after you"
- elog "have reviewed your new configuration, you are advised to remove"
- elog "the obsolete 70_mod_php5.conf file."
- elog
- fi
-}
diff --git a/app-eselect/eselect-php/eselect-php-9999.ebuild b/app-eselect/eselect-php/eselect-php-9999.ebuild
index 58c55ea1947..e6b5ef3d880 100644
--- a/app-eselect/eselect-php/eselect-php-9999.ebuild
+++ b/app-eselect/eselect-php/eselect-php-9999.ebuild
@@ -40,12 +40,6 @@ src_configure(){
src_install() {
default
- # This can be removed after a while...
- if use apache2 ; then
- insinto /etc/apache2/modules.d
- newins "${FILESDIR}/70_mod_php5.backcompat.conf" 70_mod_php5.conf
- fi
-
if use fpm ; then
systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
sed -e "s,@libdir@,$(get_libdir),g" "${FILESDIR}/php-fpm-launcher-r3" > "${T}"/php-fpm-launcher || die
@@ -53,19 +47,3 @@ src_install() {
doexe "${T}"/php-fpm-launcher
fi
}
-
-pkg_postinst() {
- if use apache2 ; then
- elog
- elog "If you are upgrading, be warned that our mod_php configuration"
- elog "file has changed! You should now define -DPHP for the apache2"
- elog "daemon, and inspect the new 70_mod_php.conf which has been"
- elog "installed. Module loading involves eselect as of this version."
- elog
- elog "You must run eselect at least once to choose your apache2 target"
- elog "before the new configuration will work. Afterwards, and after you"
- elog "have reviewed your new configuration, you are advised to remove"
- elog "the obsolete 70_mod_php5.conf file."
- elog
- fi
-}