summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-28 22:55:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-28 23:02:23 +0200
commit5f27cd2cfe23e244fc8164a2fec14dcf07c0dda6 (patch)
tree70f2f09e2d62a273bbd405210b8b70c18df138f2 /app-forensics/foremost/foremost-1.5.7-r3.ebuild
parentapp-portage/portpeek: Fix bug in is_any_cpv_file_masked (diff)
downloadgentoo-5f27cd2cfe23e244fc8164a2fec14dcf07c0dda6.tar.gz
gentoo-5f27cd2cfe23e244fc8164a2fec14dcf07c0dda6.tar.bz2
gentoo-5f27cd2cfe23e244fc8164a2fec14dcf07c0dda6.zip
app-forensics/foremost: Fix build with GCC-10/-fno-common
- EAPI-7 bump - Drop unused eutils.eclass - Drop filler word from description - Apply best practice to LICENSE-SLOT-KEYWORDS-IUSE - Break up emake block with some newlines - Fix PATCHES indendation - Add missing || die Closes: https://bugs.gentoo.org/722196 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-forensics/foremost/foremost-1.5.7-r3.ebuild')
-rw-r--r--app-forensics/foremost/foremost-1.5.7-r3.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/app-forensics/foremost/foremost-1.5.7-r3.ebuild b/app-forensics/foremost/foremost-1.5.7-r3.ebuild
index 56cdeee6ed5d..c3742c315533 100644
--- a/app-forensics/foremost/foremost-1.5.7-r3.ebuild
+++ b/app-forensics/foremost/foremost-1.5.7-r3.ebuild
@@ -1,32 +1,38 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
-DESCRIPTION="A console program to recover files based on their headers and footers"
+DESCRIPTION="Console program to recover files based on their headers and footers"
HOMEPAGE="http://foremost.sourceforge.net/"
#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
# starting to hate sf.net ...
SRC_URI="http://foremost.sourceforge.net/pkg/${P}.tar.gz"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
LICENSE="public-domain"
SLOT="0"
-PATCHES=("${FILESDIR}/${PN}-1.4-config-location.patch"
- "${FILESDIR}/${PN}-1.5.7-format-security.patch"
- "${FILESDIR}/${PN}-1.5.7-set-but-unused.patch")
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4-config-location.patch"
+ "${FILESDIR}/${PN}-1.5.7-format-security.patch" # bug 521038
+ "${FILESDIR}/${PN}-1.5.7-set-but-unused.patch" # bug 706886
+ "${FILESDIR}/${PN}-1.5.7-fno-common.patch" # bug 722196
+)
src_compile() {
- emake RAW_FLAGS="${CFLAGS} -Wall ${LDFLAGS}" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
+ emake \
+ RAW_FLAGS="${CFLAGS} -Wall ${LDFLAGS}" \
+ RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
CONF=/etc
}
src_install() {
dobin foremost
- gunzip foremost.8.gz
+ gunzip foremost.8.gz || die
doman foremost.8
insinto /etc
doins foremost.conf