summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-17 00:03:49 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-17 00:03:49 +0900
commite6bef3cffebd5442f37fc99d96cd613d845ef2b2 (patch)
tree67a0a0c7879c14f638fa1d300673a5f022f53c72 /app-i18n/libchewing
parentapp-i18n/ibus-fbterm: update DESCRIPTION (diff)
downloadgentoo-e6bef3cffebd5442f37fc99d96cd613d845ef2b2.tar.gz
gentoo-e6bef3cffebd5442f37fc99d96cd613d845ef2b2.tar.bz2
gentoo-e6bef3cffebd5442f37fc99d96cd613d845ef2b2.zip
dev-libs/libchewing: move to app-i18n/libchewing
Diffstat (limited to 'app-i18n/libchewing')
-rw-r--r--app-i18n/libchewing/Manifest2
-rw-r--r--app-i18n/libchewing/files/0.3.3-cflags.patch10
-rw-r--r--app-i18n/libchewing/files/0.3.3-strncat-fix.patch13
-rw-r--r--app-i18n/libchewing/files/0.3.3-tinfo.patch43
-rw-r--r--app-i18n/libchewing/libchewing-0.3.3-r1.ebuild50
-rw-r--r--app-i18n/libchewing/libchewing-0.3.3.ebuild47
-rw-r--r--app-i18n/libchewing/libchewing-0.4.0-r1.ebuild48
-rw-r--r--app-i18n/libchewing/metadata.xml11
8 files changed, 224 insertions, 0 deletions
diff --git a/app-i18n/libchewing/Manifest b/app-i18n/libchewing/Manifest
new file mode 100644
index 000000000000..c5123f411130
--- /dev/null
+++ b/app-i18n/libchewing/Manifest
@@ -0,0 +1,2 @@
+DIST libchewing-0.3.3.tar.bz2 1798134 SHA256 72a0de12b86c4d5f6468a68d88c736227ff16fa7a915f8595ffe5a31cae95eae SHA512 24df8d4a1dab72b32bca03bb1086223248a261d522e703c662aad53cfb16fef74691623361d275b8d811d4a0e6bc2b23b044248f7d3982dc657c9872de1de005 WHIRLPOOL 12b67dc7aa3c34fefe66bed995642d021b5c2997d706b7bb73319a0c26b3f9291c771f6308c50bc1cb3e319ff8848a09bf0aec1ed713eb55706bf11cdefdb824
+DIST libchewing-0.4.0.tar.gz 3367957 SHA256 128eae0616c8b4dadaecfb8982304241e65e2eb397001144ba5ed451ec197cc2 SHA512 8ac2a50531867dd628ed0c084a30b22e24cd102671b9ce23b008fb54d049c07135a8af205186e4ed719077cef6739e230fdcbd33cab0821a9bfab5b8fb4248c7 WHIRLPOOL a7ed4841fac60d402c710a8775b74e61bdb6ed6790ce33221bce1efc9b111192251b60bedbd04654d6afb8264d784600794be402d02c04f802bbe6ba03b54984
diff --git a/app-i18n/libchewing/files/0.3.3-cflags.patch b/app-i18n/libchewing/files/0.3.3-cflags.patch
new file mode 100644
index 000000000000..dba1093c5ae6
--- /dev/null
+++ b/app-i18n/libchewing/files/0.3.3-cflags.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -153,7 +122,6 @@
+ if test x$LIBDEBUG = x"true"; then
+ AC_DEFINE(ENABLE_DEBUG, 1,
+ [Define to 1 if you want native library runtime debugging code enabled])
+- CFLAGS="$CFLAGS -g"
+ fi
+ AC_SUBST(LIBDEBUG)
+
diff --git a/app-i18n/libchewing/files/0.3.3-strncat-fix.patch b/app-i18n/libchewing/files/0.3.3-strncat-fix.patch
new file mode 100644
index 000000000000..8f2676c0c2b7
--- /dev/null
+++ b/app-i18n/libchewing/files/0.3.3-strncat-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/src/tree.c b/src/tree.c
+index 7e8f665..89ad0d5 100644
+--- a/src/tree.c
++++ b/src/tree.c
+@@ -586,7 +586,7 @@ static void LoadChar( char *buf, int buf_len, uint16 phoneSeq[], int nPhoneSeq )
+ memset(buf, 0, buf_len);
+ for ( i = 0; i < nPhoneSeq; i++ ) {
+ GetCharFirst( &word, phoneSeq[ i ] );
+- strncat(buf, word.word, buf_len);
++ strncat(buf, word.word, buf_len - strlen(buf) - 1);
+ }
+ buf[ buf_len - 1 ] = '\0';
+ }
diff --git a/app-i18n/libchewing/files/0.3.3-tinfo.patch b/app-i18n/libchewing/files/0.3.3-tinfo.patch
new file mode 100644
index 000000000000..10692e72c8ed
--- /dev/null
+++ b/app-i18n/libchewing/files/0.3.3-tinfo.patch
@@ -0,0 +1,43 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -91,38 +91,8 @@
+ AM_CONDITIONAL(ENABLE_UNIT_TEST, test x$enable_check = "xyes")
+
+ # Checks for ncursesw
+-OLDCFLAGS=$CFLAGS
+-LIB_NAME=ncursesw
+-NCURSESW_CFLAGS=
+-NCURSESW_LIBS=
+-for p in "$HOME/include" "$prefix/include" /usr/local/include /usr/include
+-do
+- if test -f "$p/ncursesw/ncurses.h"
+- then
+- NCURSESW_CFLAGS="-I$p"
+- AC_DEFINE(HAVE_NCURSESW_NCURSES_H, 1, [ Define to 1 if you have the <ncursesw/ncurses.h> header file. ])
+- break
+- elif test -f "$p/ncurses/ncurses.h"
+- then
+- NCURSESW_CFLAGS="-I$p"
+- AC_DEFINE(HAVE_NCURSES_NCURSES_H, 1, [ Define to 1 if you have the <ncurses/ncurses.h> header file. ])
+- break
+- fi
+-done
+-
+-for p in "$HOME/lib" "$prefix/lib" /usr/local/lib /usr/lib
+-do
+- if test -f "$p/libncursesw.so"
+- then
+- if test "$p" != x/usr/lib
+- then
+- NCURSESW_LIBS="-L$p -lncursesw"
+- else
+- NCURSESW_LIBS="-lncursesw"
+- fi
+- break
+- fi
+-done
++PKG_CHECK_MODULES(NCURSESW,ncursesw,
++ AC_DEFINE(HAVE_NCURSESW_NCURSES_H, 1, [ Define to 1 if you have the <ncursesw/ncurses.h> header file. ]),)
+
+ enable_ncursesw=yes
+ if test -z "$NCURSESW_CFLAGS"; then
diff --git a/app-i18n/libchewing/libchewing-0.3.3-r1.ebuild b/app-i18n/libchewing/libchewing-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..44ef3bd839e2
--- /dev/null
+++ b/app-i18n/libchewing/libchewing-0.3.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="Library for Chinese Phonetic input method"
+HOMEPAGE="http://chewing.csie.net/"
+SRC_URI="http://chewing.csie.net/download/libchewing/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs test"
+
+DEPEND="
+ virtual/pkgconfig
+ test? (
+ sys-libs/ncurses[unicode]
+ >=dev-libs/check-0.9.4
+ )
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-cflags.patch \
+ "${FILESDIR}"/${PV}-strncat-fix.patch \
+ "${FILESDIR}"/${PV}-tinfo.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ # test subdirectory is not enabled by default; this means that we
+ # have to make it explicit.
+ emake -C test check
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_install() {
+ default
+
+ prune_libtool_files
+}
diff --git a/app-i18n/libchewing/libchewing-0.3.3.ebuild b/app-i18n/libchewing/libchewing-0.3.3.ebuild
new file mode 100644
index 000000000000..9cc0a48e064c
--- /dev/null
+++ b/app-i18n/libchewing/libchewing-0.3.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="Library for Chinese Phonetic input method"
+HOMEPAGE="http://chewing.csie.net/"
+SRC_URI="http://chewing.csie.net/download/libchewing/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE="debug test static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ sys-libs/ncurses[unicode]
+ >=dev-libs/check-0.9.4
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-strncat-fix.patch
+}
+
+src_configure() {
+ export CC_FOR_BUILD="$(tc-getBUILD_CC)"
+ econf $(use_enable debug) \
+ $(use_enable static-libs static) || die
+}
+
+src_test() {
+ # test subdirectory is not enabled by default; this means that we
+ # have to make it explicit.
+ emake -C test check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ find "${ED}"usr/$(get_libdir)/ -name '*.la' -delete || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+}
diff --git a/app-i18n/libchewing/libchewing-0.4.0-r1.ebuild b/app-i18n/libchewing/libchewing-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..a2a73dc6986f
--- /dev/null
+++ b/app-i18n/libchewing/libchewing-0.4.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="Library for Chinese Phonetic input method"
+HOMEPAGE="http://chewing.csie.net/"
+SRC_URI="https://github.com/chewing/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc ppc64 ~x86"
+IUSE="static-libs test"
+
+DEPEND="
+ virtual/pkgconfig
+ test? (
+ sys-libs/ncurses[unicode]
+ >=dev-libs/check-0.9.4
+ )
+ dev-db/sqlite:3
+"
+
+DOCS=( AUTHORS NEWS README.md TODO )
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --with-sqlite3 \
+ --disable-gcov
+}
+
+src_test() {
+ # test subdirectory is not enabled by default; this means that we
+ # have to make it explicit.
+ emake -C test check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/app-i18n/libchewing/metadata.xml b/app-i18n/libchewing/metadata.xml
new file mode 100644
index 000000000000..baa53a1242c5
--- /dev/null
+++ b/app-i18n/libchewing/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">chewing/libchewing</remote-id>
+ </upstream>
+</pkgmetadata>