summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-08-06 18:47:03 +0200
committerPacho Ramos <pacho@gentoo.org>2019-08-06 18:47:19 +0200
commit88095ceae7c44e2739e862df27fd2193b39ddd2a (patch)
tree0edd815aa14fdec3054d5f1e4a53663df65982ce /app-i18n/libskk
parentnet-wireless/unifi: bump to 5.10.27 (diff)
downloadgentoo-88095ceae7c44e2739e862df27fd2193b39ddd2a.tar.gz
gentoo-88095ceae7c44e2739e862df27fd2193b39ddd2a.tar.bz2
gentoo-88095ceae7c44e2739e862df27fd2193b39ddd2a.zip
Revert "app-i18n/libskk: Drop old"
This reverts commit 817343f2589492047c20295571c1933615d349f8. Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-i18n/libskk')
-rw-r--r--app-i18n/libskk/Manifest1
-rw-r--r--app-i18n/libskk/libskk-1.0.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-i18n/libskk/Manifest b/app-i18n/libskk/Manifest
index ab428f2bac66..557f4b43502b 100644
--- a/app-i18n/libskk/Manifest
+++ b/app-i18n/libskk/Manifest
@@ -1 +1,2 @@
+DIST libskk-1.0.1.tar.gz 860453 BLAKE2B 95f386e34f479548c7b4a37c3d70d16e27fd238a83e09c9dfc539ec9c3cc1466bea6a1d694e9b1027d66955053b2af1719a96ea4b5a37f61fda82118250576cf SHA512 17dc7c0361083c08c29267b4fe2d066b079e5156728f461717044f99579ec2674b56c960d2be5a42a2dffb693106d2d3d78ec8cb833e8f189d48e421a25d91b0
DIST libskk-1.0.2.tar.gz 867572 BLAKE2B 32f599e83bf7ced796d2f37f6f4bf5e45f47c90e144784b7b3e082866cc619a26e3aca4f16051685baa4d8ac54b0462930193f978bc1e8220b378679269c5833 SHA512 f8fff94b216c18f66bf1004ee068f8d737177f1b70ac36d054d9a68ce02ba9b8d1b7b4127d9a330f64054b2fe06f352070c750a3562d4be36fecf20cb854e6c0
diff --git a/app-i18n/libskk/libskk-1.0.1.ebuild b/app-i18n/libskk/libskk-1.0.1.ebuild
new file mode 100644
index 000000000000..9dfbf773269b
--- /dev/null
+++ b/app-i18n/libskk/libskk-1.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit ltprune vala virtualx
+
+DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
+HOMEPAGE="https://github.com/ueno/libskk"
+SRC_URI="https://bitbucket.org/${PN}/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+introspection nls static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0
+ introspection? ( dev-libs/gobject-introspection )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ vala_src_prepare
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ export GSETTINGS_BACKEND="memory"
+ virtx emake check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}