summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-12-23 20:31:34 +0000
committerMike Gilbert <floppym@gentoo.org>2019-12-29 14:31:29 -0500
commite0f9705d877888eeb0615fb586d917f34ff48dd9 (patch)
treefa3f1af65968e1f13b9ad9a418031fe0b83991b8 /app-i18n/mozc/mozc-9999.ebuild
parentsys-boot/grub: update LICENSE (diff)
downloadgentoo-e0f9705d877888eeb0615fb586d917f34ff48dd9.tar.gz
gentoo-e0f9705d877888eeb0615fb586d917f34ff48dd9.tar.bz2
gentoo-e0f9705d877888eeb0615fb586d917f34ff48dd9.zip
app-i18n/mozc: Support environmental variables.
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n/mozc/mozc-9999.ebuild')
-rw-r--r--app-i18n/mozc/mozc-9999.ebuild36
1 files changed, 32 insertions, 4 deletions
diff --git a/app-i18n/mozc/mozc-9999.ebuild b/app-i18n/mozc/mozc-9999.ebuild
index ceddd8af71a0..f1d9151c2650 100644
--- a/app-i18n/mozc/mozc-9999.ebuild
+++ b/app-i18n/mozc/mozc-9999.ebuild
@@ -44,10 +44,10 @@ BDEPEND="${PYTHON_DEPS}
dev-util/gyp
dev-util/ninja
virtual/pkgconfig
- emacs? ( >=app-editors/emacs-23.1:* )
+ emacs? ( app-editors/emacs:* )
fcitx4? ( sys-devel/gettext )"
RDEPEND=">=dev-libs/protobuf-3.0.0:=
- emacs? ( >=app-editors/emacs-23.1:* )
+ emacs? ( app-editors/emacs:* )
fcitx4? (
app-i18n/fcitx:4
virtual/libintl
@@ -108,6 +108,7 @@ src_prepare() {
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-system_libraries.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-gcc-8.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-protobuf_generated_classes_no_inheritance.patch"
+ eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-environmental_variables.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-reiwa.patch"
eapply -p2 "${FILESDIR}/${PN}-2.20.2673.102-tests_build.patch"
eapply -p2 "${FILESDIR}/${PN}-2.20.2673.102-tests_skipping.patch"
@@ -303,9 +304,33 @@ src_install() {
}
pkg_postinst() {
+ elog
+ elog "ENVIRONMENTAL VARIABLES"
+ elog
+ elog "MOZC_SERVER_DIRECTORY"
+ elog " Mozc server directory"
+ elog " Value used by default: \"${EPREFIX}/usr/libexec/mozc\""
+ elog "MOZC_DOCUMENTS_DIRECTORY"
+ elog " Mozc documents directory"
+ elog " Value used by default: \"${EPREFIX}/usr/libexec/mozc/documents\""
+ elog "MOZC_CONFIGURATION_DIRECTORY"
+ elog " Mozc configuration directory"
+ elog " Value used by default: \"~/.mozc\""
+ if use gui; then
+ elog "MOZC_ZINNIA_MODEL_FILE"
+ elog " Zinnia handwriting recognition model file"
+ if use handwriting-tegaki; then
+ elog " Value used by default: \"${EPREFIX}/usr/share/tegaki/models/zinnia/handwriting-ja.model\""
+ elif use handwriting-tomoe; then
+ elog " Value used by default: \"${EPREFIX}/usr/$(get_libdir)/zinnia/model/tomoe/handwriting-ja.model\""
+ fi
+ elog " Potential values:"
+ elog " \"${EPREFIX}/usr/share/tegaki/models/zinnia/handwriting-ja.model\""
+ elog " \"${EPREFIX}/usr/$(get_libdir)/zinnia/model/tomoe/handwriting-ja.model\""
+ fi
+ elog
if use emacs; then
- elisp-site-regen
-
+ elog
elog "USAGE IN EMACS"
elog
elog "mozc-mode is minor mode to input Japanese text using Mozc server."
@@ -323,6 +348,9 @@ pkg_postinst() {
elog
elog "Alternatively, at run time, after loading mozc.el, mozc-mode can be activated by"
elog "calling \"set-input-method\" and entering \"japanese-mozc\"."
+ elog
+
+ elisp-site-regen
fi
}