summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-25 22:32:12 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-25 22:37:02 +0200
commita3bb3de8b35f81c239d2c3b85e6c7bbe335ebd50 (patch)
treeac03e4bd2caef44c89a5fc256539c68232888cdb /app-i18n/scim
parentapp-admin/keepassxc: Removed old. (diff)
downloadgentoo-a3bb3de8b35f81c239d2c3b85e6c7bbe335ebd50.tar.gz
gentoo-a3bb3de8b35f81c239d2c3b85e6c7bbe335ebd50.tar.bz2
gentoo-a3bb3de8b35f81c239d2c3b85e6c7bbe335ebd50.zip
app-i18n/scim: Remove dep on removed qt4
Diffstat (limited to 'app-i18n/scim')
-rw-r--r--app-i18n/scim/scim-1.4.17.ebuild9
-rw-r--r--app-i18n/scim/scim-1.4.18.ebuild9
2 files changed, 4 insertions, 14 deletions
diff --git a/app-i18n/scim/scim-1.4.17.ebuild b/app-i18n/scim/scim-1.4.17.ebuild
index 86a88efe10b..e8653806f6b 100644
--- a/app-i18n/scim/scim-1.4.17.ebuild
+++ b/app-i18n/scim/scim-1.4.17.ebuild
@@ -11,16 +11,12 @@ SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc gtk3 qt4"
+IUSE="doc gtk3"
RDEPEND="x11-libs/libX11
dev-libs/glib:2
gtk3? ( x11-libs/gtk+:3 )
!gtk3? ( x11-libs/gtk+:2 )
- qt4? (
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- )
>=dev-libs/atk-1
>=x11-libs/pango-1"
DEPEND="${RDEPEND}
@@ -50,8 +46,7 @@ src_configure() {
--enable-ld-version-script \
$(usex gtk3 --with-gtk-version={3,2}) \
--disable-qt3-immodule \
- $(use_enable qt4 qt4-immodule) \
- --with-qt4-moc="$(qt4_get_bindir)/moc"
+ --disable-qt4-immodule
}
src_compile() {
diff --git a/app-i18n/scim/scim-1.4.18.ebuild b/app-i18n/scim/scim-1.4.18.ebuild
index cf10edfec8e..4279a7029e8 100644
--- a/app-i18n/scim/scim-1.4.18.ebuild
+++ b/app-i18n/scim/scim-1.4.18.ebuild
@@ -12,16 +12,12 @@ SRC_URI="https://github.com/scim-im/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc gtk3 qt4"
+IUSE="doc gtk3"
RDEPEND="x11-libs/libX11
dev-libs/glib:2
gtk3? ( x11-libs/gtk+:3 )
!gtk3? ( x11-libs/gtk+:2 )
- qt4? (
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- )
>=dev-libs/atk-1
>=x11-libs/pango-1"
DEPEND="${RDEPEND}
@@ -51,8 +47,7 @@ src_configure() {
--enable-ld-version-script \
$(usex gtk3 --with-gtk-version={3,2}) \
--disable-qt3-immodule \
- $(use_enable qt4 qt4-immodule) \
- --with-qt4-moc="$(qt4_get_bindir)/moc"
+ --disable-qt4-immodule
}
src_compile() {