summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-07-29 23:44:09 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-07-29 23:44:09 +0900
commitaad6ad38fa58fa5e4c9d55902d11447acba29bb8 (patch)
treef0ccb550b217fe1df0a5265eec353e457390b1bc /app-i18n
parentapp-i18n/ibus-m17n: drop old (diff)
downloadgentoo-aad6ad38fa58fa5e4c9d55902d11447acba29bb8.tar.gz
gentoo-aad6ad38fa58fa5e4c9d55902d11447acba29bb8.tar.bz2
gentoo-aad6ad38fa58fa5e4c9d55902d11447acba29bb8.zip
app-i18n/ibus-table: new upstream release
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-table/Manifest1
-rw-r--r--app-i18n/ibus-table/ibus-table-1.14.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index 280272929e62..ff14b1579adf 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1,2 +1,3 @@
DIST ibus-table-1.12.4.tar.gz 1371890 BLAKE2B e0d531bdd38e536ac9fc92465a651e971969278ab4826198d12399ebb1cd747d1f5d21713ecc86311ab3995b04a2842d230da8caed962045a959ba136f197cb1 SHA512 3e175dad8d9e12be91f6b6878b67301bbbf04c55e43d483162d3b10d2edbdcf1077d1f37beea2ef36323eb7de289a0c60cd3d055357a580e5d18bcc642bb907c
DIST ibus-table-1.13.3.tar.gz 1408143 BLAKE2B fda380e284a996d34053f6bae543ebc2c072ffbd870a9421b76f18a3fa5e45ca6e687818f40bd1335791f1b92dc7ffa1ccc35c7cb55d1a6ade26bc958a2bf8d4 SHA512 2959b2f96c9a490032dafbce2b4164fcc07797ab73e735f26003156a891e1e3760e6a4f42713084b5ce1e408cbe21c3060d99615d898fe50b8d51405dcd42a3b
+DIST ibus-table-1.14.0.tar.gz 1450310 BLAKE2B 72a655e378b39324ff849e6941dc28920760d030d748a5b4b0899e14b94874a52581d03ccbef2d72c5eaae51d20a0e19690bde5a1411960347fe49cf3137d21b SHA512 60e570b82c4f05200410e9e4e155089223a20ebcf66d1c039a783108005f63699e75bc528fc30cd370c1400b65e765ade0d069184bd2ab81e2eda9bade2e8ac9
diff --git a/app-i18n/ibus-table/ibus-table-1.14.0.ebuild b/app-i18n/ibus-table/ibus-table-1.14.0.ebuild
new file mode 100644
index 000000000000..ff60ef200c5d
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.14.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}