summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-01-28 13:43:57 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-01-28 13:46:25 -0500
commit5c79004d714afbcc32715669e63d9722be884f6a (patch)
treef7629ece5d4e8cba00d4b935922c61dbd7f144cd /app-laptop/hdapsd
parentmedia-libs/openal: remove unused usedescs (diff)
downloadgentoo-5c79004d714afbcc32715669e63d9722be884f6a.tar.gz
gentoo-5c79004d714afbcc32715669e63d9722be884f6a.tar.bz2
gentoo-5c79004d714afbcc32715669e63d9722be884f6a.zip
app-laptop/hdapsd: remove old 20090401 version and its files.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-laptop/hdapsd')
-rw-r--r--app-laptop/hdapsd/Manifest1
-rw-r--r--app-laptop/hdapsd/files/hdapsd.conf.312
-rw-r--r--app-laptop/hdapsd/files/hdapsd.init.369
-rw-r--r--app-laptop/hdapsd/hdapsd-20090401-r2.ebuild51
4 files changed, 0 insertions, 133 deletions
diff --git a/app-laptop/hdapsd/Manifest b/app-laptop/hdapsd/Manifest
index 0e9092b1e14..a460ec35fc0 100644
--- a/app-laptop/hdapsd/Manifest
+++ b/app-laptop/hdapsd/Manifest
@@ -1,2 +1 @@
-DIST hdapsd-20090401.tar.gz 95058 SHA256 32979d58de4c54a7cc5671e7e7b4f0b653b659104faa9610433f8bb5dd4cef7a SHA512 4984a6c636d3447051ca5629fec89f08eee3773750f9623b80d7c0d4af65dcf9868392f2e93f5d13ac329d311ec2ebcdddf3e438007d1f851a920137c6903c96 WHIRLPOOL 9c3822acb39ff1f10e47604725bf6e42546b95ba9db26ebd751b69c4162e3df4f33d177a2a0b7a764c5e0f2478f470595cda304221a0ec165b07ef183b6ea9be
DIST hdapsd-20141203.tar.gz 128818 SHA256 6650db6b2251b9774bdfba34dd58f712de4c761e6c78eb61ea3b82b694cbef5e SHA512 19c1a8b362f15864b71f4fb221c0993b43b3b2d965d5826af06fb9f6b0e345e5da99181493e13e230c7fe77060ae5b373027e8ec90a511566a6ccaef43998178 WHIRLPOOL befbcbbdcfc5ae9a844f0a96703a7c9a7d43bf4c5d6d9735412efc136d9e20aff6a4dc3e5755cfa9837122b4f7890b00be53a21237838b078271ba7c9650589c
diff --git a/app-laptop/hdapsd/files/hdapsd.conf.3 b/app-laptop/hdapsd/files/hdapsd.conf.3
deleted file mode 100644
index 509d3afa201..00000000000
--- a/app-laptop/hdapsd/files/hdapsd.conf.3
+++ /dev/null
@@ -1,12 +0,0 @@
-# The list of the disk devices that hdapsd should monitor.
-# Usually this is 'hda', 'sda' or 'hda sda'.
-# hdaps will auto-devices if empty
-#DISKLIST="sda"
-
-# hdapsd sensitivity
-# The lower the threshold is the earlier
-# the heads are parked when the laptop is shaked
-THRESHOLD="10"
-
-# Set any extra options here, like -a for Adaptive mode
-OPTIONS="-a"
diff --git a/app-laptop/hdapsd/files/hdapsd.init.3 b/app-laptop/hdapsd/files/hdapsd.init.3
deleted file mode 100644
index d7894fbc8ad..00000000000
--- a/app-laptop/hdapsd/files/hdapsd.init.3
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2
-
-depend() {
- need localmount
-}
-
-checkconfig() {
- if [ -n "${DISK}" ]; then
- ewarn "Please migrate DISK to DISKLIST in /etc/conf.d/hdapsd."
- DISKLIST=${DISK}
- fi
-
- if [ -z "${THRESHOLD}" ] ; then
- eerror "You should setup THRESHOLD in /etc/conf.d/hdapsd."
- return 1
- fi
-
- #empty DISKLIST is allowed as well
- for DISK in ${DISKLIST}; do
- if [ ! -b /dev/${DISK} ]; then
- eerror "Could not find disk /dev/${DISK}!"
- eerror "Adjust the DISK setting in /etc/conf.d/hdapsd"
- return 1
- fi
-
- if [ ! -e /sys/block/${DISK}/queue/protect ] && [ ! -e /sys/block/${DISK}/device/unload_heads ] ; then
- eerror "No protect entry for ${DISK}!"
- eerror "Make sure your kernel is patched with the blk_freeze patch"
- return 1
- fi
- done
-
- # Load the tp_smapi module first
- # This is not a requirement, but it helps hdapsd adaptive mode
- if [ ! -e /sys/devices/platform/smapi ] ; then
- modprobe tp_smapi 2>/dev/null
- fi
-
- if [ ! -d /sys/devices/platform/hdaps ] ; then
- ebegin "Loading hdaps module"
- modprobe hdaps
- eend $? || return 1
- fi
-}
-
-start() {
- checkconfig || return 1
-
- local DISKOPTS DISK
- for DISK in ${DISKLIST}; do
- DISKOPTS="${DISKOPTS} -d ${DISK}"
- done
-
- ebegin "Starting Hard Drive Active Protection System daemon"
- start-stop-daemon --start --exec /usr/sbin/hdapsd \
- --pidfile /var/run/hdapsd.pid \
- -- --syslog --background --pidfile \
- ${DISKOPTS} --sensitivity "${THRESHOLD}" ${OPTIONS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping Hard Drive Active Protection System daemon"
- start-stop-daemon --stop --exec /usr/sbin/hdapsd \
- --pidfile /var/run/hdapsd.pid
- eend $?
-}
diff --git a/app-laptop/hdapsd/hdapsd-20090401-r2.ebuild b/app-laptop/hdapsd/hdapsd-20090401-r2.ebuild
deleted file mode 100644
index 42abdeeee8d..00000000000
--- a/app-laptop/hdapsd/hdapsd-20090401-r2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-inherit linux-info readme.gentoo
-
-DESCRIPTION="IBM ThinkPad Harddrive Active Protection disk head parking daemon"
-HOMEPAGE="http://hdaps.sourceforge.net/"
-SRC_URI="mirror://sourceforge/hdaps/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-pkg_setup() {
- # We require the hdaps module which can either come from kernel sources
- # or from the tp_smapi package.
- if ! has_version app-laptop/tp_smapi[hdaps]; then
- CONFIG_CHECK="~SENSORS_HDAPS"
- ERROR_SENSORS_HDAPS="${P} requires app-laptop/tp_smapi (with hdaps USE enabled) or support for CONFIG_SENSORS_HDAPS enabled"
- linux-info_pkg_setup
- fi
-
- DOC_CONTENTS="You can change the default frequency by modifing /sys/devices/platform/hdaps/sampling_rate.
- You might need to enable shock protection manually by running:\n
- # echo -1 > /sys/block/DEVICE/device/unload_heads"
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
- rm -rf "${ED}"/usr/share/doc/hdapsd
- dodoc ChangeLog README AUTHORS
- newconfd "${FILESDIR}"/hdapsd.conf.3 hdapsd
- newinitd "${FILESDIR}"/hdapsd.init.3 hdapsd
- readme.gentoo_create_doc
-}
-
-pkg_postinst(){
- [[ -z $(ls ${EROOT}/sys/block/*/queue/protect 2>/dev/null) ]] && \
- [[ -z $(ls ${EROOT}/sys/block/*/device/unload_heads 2>/dev/null) ]] && \
- ewarn "Your kernel does NOT support shock protection. Kernel 2.6.28 and above is recommended!"
-
- if ! has_version app-laptop/tp_smapi[hdaps]; then
- ewarn "Using the hdaps module provided by app-laptop/tp_smapi instead"
- ewarn "of the in-kernel driver is strongly recommended!"
- fi
-
- readme.gentoo_print_elog
-}