summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-10 04:50:36 +0100
committerSam James <sam@gentoo.org>2022-06-10 04:50:36 +0100
commitbbaeaf9218b0bc5665b657155625e677e512161a (patch)
tree6e88909cb399897ea5a33f282749095eeaf5d67e /app-laptop/msi-keyboard/msi-keyboard-1.0-r1.ebuild
parentmedia-libs/tg_owt: fix build with GCC 12 (diff)
downloadgentoo-bbaeaf9218b0bc5665b657155625e677e512161a.tar.gz
gentoo-bbaeaf9218b0bc5665b657155625e677e512161a.tar.bz2
gentoo-bbaeaf9218b0bc5665b657155625e677e512161a.zip
app-laptop/msi-keyboard: fix build with GCC 12; respect CXX
Closes: https://bugs.gentoo.org/840329 Closes: https://bugs.gentoo.org/722324 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-laptop/msi-keyboard/msi-keyboard-1.0-r1.ebuild')
-rw-r--r--app-laptop/msi-keyboard/msi-keyboard-1.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-laptop/msi-keyboard/msi-keyboard-1.0-r1.ebuild b/app-laptop/msi-keyboard/msi-keyboard-1.0-r1.ebuild
new file mode 100644
index 000000000000..65aff6060bd4
--- /dev/null
+++ b/app-laptop/msi-keyboard/msi-keyboard-1.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs udev
+
+DESCRIPTION="Control backlight of MSI laptop keyboards"
+HOMEPAGE="https://github.com/makkarpov/msi-keyboard"
+SRC_URI="https://github.com/makkarpov/msi-keyboard/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/hidapi"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-r1-makefile.patch
+ "${FILESDIR}"/${P}-gcc12.patch
+)
+
+src_configure() {
+ tc-export CXX
+}
+
+src_install() {
+ udev_dorules 99-msi-keyboard.rules
+ dobin msi-keyboard
+}
+
+pkg_prerm() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}