summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-09-12 13:35:50 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-09-13 13:44:58 +0200
commitb14d75475b5090d7913ea9851d619817d1e04259 (patch)
tree17129c0f6d77d88a6e9387df4e1e41f3580bc161 /app-metrics/prometheus
parentapp-admin/lib_users: Mark 0.11 stable (diff)
downloadgentoo-b14d75475b5090d7913ea9851d619817d1e04259.tar.gz
gentoo-b14d75475b5090d7913ea9851d619817d1e04259.tar.bz2
gentoo-b14d75475b5090d7913ea9851d619817d1e04259.zip
app-metrics/prometheus: Version bump to 2.4.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-metrics/prometheus')
-rw-r--r--app-metrics/prometheus/Manifest1
-rw-r--r--app-metrics/prometheus/prometheus-2.4.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index 79a3f861bf07..ad1644be789d 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -1,3 +1,4 @@
DIST prometheus-2.2.1.tar.gz 5629500 BLAKE2B 7645267a2c5ed1c4138a5dd3929a48cb9dfa27789db38e98addbb06c37c6b482abfcf296ef1a5836bebd971d8224136c24a4ccd3093175882bb0beda1673deff SHA512 a94cf867de2b3be65b0a07307f89ebfa9c0a319820a72b3b6691edcd2e2b56b5268d27fb52bdaefea0e7084906d69b818e5292a39ccd5991e04e56d594f56ea7
DIST prometheus-2.3.1.tar.gz 6175030 BLAKE2B 395808ce10eee18469a34caa7a358325830717cce7199f4cd3e6da346326573e65695cd444ad1c37586f9744db51808ef78f4a50fac971fa0fbc7fd7a4089994 SHA512 f0930a8de3885f9d870d41b41b602cd19addaa362d0473c95723b6cff32fd28870f8d47c89b9d39e13f43e189ad991d7569baa1a6ecd1ca59ba85cbb3d3cd6b1
DIST prometheus-2.3.2.tar.gz 6175804 BLAKE2B 98d7fe58043e5104b6eb181edd13a2aec3c347ae6d0325f08a267b02eef3bd8963603fb17c113244b47967a549ebe860f2a3f11e297ceca85b57495df7f19070 SHA512 35bd654f3326d36846654775e924821de9efc7b39c93d5ffc5e8f4db6feb456cf3b8833de3aa3df9d9f63481c487f2633b55b9610cef4e7a037f2a9b1ffbbd23
+DIST prometheus-2.4.0.tar.gz 6090871 BLAKE2B 553d3292abfc58aba11e14786892b7dfc9ace00b29bba38a964e5b36113a4827759f5229d36693be225aca0962d7577751a8778201929b1f987a000fe31c2544 SHA512 a2fc7d67ac2fd8e17b5c69983daa385fe042e88c8c00ce71c51ae0e66d3cba201bcc7ef52ce34bef9724df002769c6fd9ee44115f397e253859f4c3f77427839
diff --git a/app-metrics/prometheus/prometheus-2.4.0.ebuild b/app-metrics/prometheus/prometheus-2.4.0.ebuild
new file mode 100644
index 000000000000..aa5bbf88634d
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.4.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_rc/-rc.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="068eaa5"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/go-1.10
+ dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}