summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-03-02 18:27:44 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-03-02 18:27:44 +0100
commit1e2aef3dbd51e3700670b81a1d8997dc5f6548fc (patch)
tree3aef5398e71e42a879bce23d1b3bc273b0306855 /app-metrics
parentsys-apps/dbus: alpha stable wrt bug #655068 (diff)
downloadgentoo-1e2aef3dbd51e3700670b81a1d8997dc5f6548fc.tar.gz
gentoo-1e2aef3dbd51e3700670b81a1d8997dc5f6548fc.tar.bz2
gentoo-1e2aef3dbd51e3700670b81a1d8997dc5f6548fc.zip
app-metrics/prometheus: Version bump to 2.7.2
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus/Manifest1
-rw-r--r--app-metrics/prometheus/prometheus-2.7.2.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index 5e755da5ca7c..c1cf35175777 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -1,3 +1,4 @@
DIST prometheus-2.4.3.tar.gz 6095284 BLAKE2B 9b9d54cf8ed61453d63e4b93cd81cd1c08a732b2238830aa1b83b63076205569b8f947a94d0528b910c0958bc77f98605ab3eaf98a1e93d361ea6b431d5df48c SHA512 c86ce48416d32ca4310315dd7195a6ee471244b7a9323ddc49270c2b885bda38c2922047dc8fd7d9b19c9f62f8bc788d30387d38f956cbf04130d7041f9a479b
DIST prometheus-2.6.1.tar.gz 6612143 BLAKE2B 33dc64406dd45f494720a1ff5f6d09ed4b45b3880b15626ab7455909258addc5d1549d3edbf8af9a374516930b297c5bdb6ef51a78cac3cb338357896c0d71ae SHA512 80bf6afa00b60aa4245a53e275a2b9579a7936609aba4ffacbbe478f34e530208e0498d8c5ea53dd3a940726e05bd6fac19fed3d6d9dd209af565d5368b2340f
DIST prometheus-2.7.1.tar.gz 7276631 BLAKE2B 1066204eebd8e9589ce5972c78f1c56c74ae40739e850731beb7c39a6100aa0c252b444571cffb6cedabddd71f0b6f927e52ce4ebb35a7fd061ed5e4d50436f7 SHA512 d9a9a5cfca48b6a5ea5dda2b319f8c498b11e0e0a4ce0d18fc4d59fba9e5337048120ba12b29d18b957ac5c268f8c17996a9e88ff9ed1e3041d0ed00bc1454d0
+DIST prometheus-2.7.2.tar.gz 7276689 BLAKE2B 4fa1325b0f68bd33f4db45d3ea0fcac24bc1319284086d3ee0d3aa65c1a4ab4c37a1a67fd6e1de74e851dd90d50b566f5a1fa5b68b11c3defefd2506f5b4ce98 SHA512 3dc46069581c457005de0eefe777e93ae72b73c624d7c728973f3c64c34d68628da13d76e3527e3825309d543fd81ef7446c776e0772c1f6bf58e5ebad805973
diff --git a/app-metrics/prometheus/prometheus-2.7.2.ebuild b/app-metrics/prometheus/prometheus-2.7.2.ebuild
new file mode 100644
index 000000000000..8b59b4be8529
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.7.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=v${PV/_rc/-rc.}
+PROMETHEUS_COMMIT="82f98c8"
+ARCHIVE_URI="https://${EGO_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/go-1.10
+ dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GO111MODULE=on GOPATH="${S}" GOCACHE="${T}/go-cache" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}