summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-06-07 14:57:06 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-06-07 14:57:06 +0200
commit1f70ea3241f03e01cbb3abd6ee27d5efba0e41a0 (patch)
tree7095efba7bfd46fdc97977b68693ed2f03214403 /app-metrics
parentsys-kernel/linux-firmware: Update snapshot (diff)
downloadgentoo-1f70ea3241f03e01cbb3abd6ee27d5efba0e41a0.tar.gz
gentoo-1f70ea3241f03e01cbb3abd6ee27d5efba0e41a0.tar.bz2
gentoo-1f70ea3241f03e01cbb3abd6ee27d5efba0e41a0.zip
app-metrics/prometheus: Version bump to 2.3.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus/Manifest1
-rw-r--r--app-metrics/prometheus/prometheus-2.3.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index d146b4c34368..cfa5cbcf34e3 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -1 +1,2 @@
DIST prometheus-2.2.1.tar.gz 5629500 BLAKE2B 7645267a2c5ed1c4138a5dd3929a48cb9dfa27789db38e98addbb06c37c6b482abfcf296ef1a5836bebd971d8224136c24a4ccd3093175882bb0beda1673deff SHA512 a94cf867de2b3be65b0a07307f89ebfa9c0a319820a72b3b6691edcd2e2b56b5268d27fb52bdaefea0e7084906d69b818e5292a39ccd5991e04e56d594f56ea7
+DIST prometheus-2.3.0.tar.gz 6171790 BLAKE2B bf08aaa124925a6fa1f610117919b5d4d15f4f4a71ff1bed1edca588b7cd4a14483a7ecbf3b3aaf5bfabe968290732b9fe3da522f726b673e0b910d2be3ead3e SHA512 2ab2bc2cc7c9bd9cafa16f54e24845b2e5c4b923bbc200ad9efae985b56587752892a364f08673e34278e6f8ad0b477482eec56632b281212af13a9110940aca
diff --git a/app-metrics/prometheus/prometheus-2.3.0.ebuild b/app-metrics/prometheus/prometheus-2.3.0.ebuild
new file mode 100644
index 000000000000..f437abf471ab
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_rc/-rc.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="290d717"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/go-1.10
+ dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}