summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-12-18 13:05:37 +0100
committerMichael Weber <xmw@gentoo.org>2017-12-18 13:05:37 +0100
commitf847d777f140a6e6c66d330f1061b068b25b947f (patch)
treead61610d0c39083b431495dfb8f731a6e09bcc4b /app-misc/anki
parentdev-db/sqlitebrowser: Fix tests, thanks Jouni Kosonen. (diff)
downloadgentoo-f847d777f140a6e6c66d330f1061b068b25b947f.tar.gz
gentoo-f847d777f140a6e6c66d330f1061b068b25b947f.tar.bz2
gentoo-f847d777f140a6e6c66d330f1061b068b25b947f.zip
app-misc/anki: Fix dependencies.
Thanks thanks Michael Mounteney and Dennis New. EAPI=6, remove unneeded overrides of src_configure and src_compile. Closes: https://bugs.gentoo.org/639354 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-misc/anki')
-rw-r--r--app-misc/anki/anki-2.1.0_beta25.ebuild26
-rw-r--r--app-misc/anki/files/anki-2.1.0_beta25-web-folder.patch11
2 files changed, 25 insertions, 12 deletions
diff --git a/app-misc/anki/anki-2.1.0_beta25.ebuild b/app-misc/anki/anki-2.1.0_beta25.ebuild
index ac3413e622b6..65fedfcbf81b 100644
--- a/app-misc/anki/anki-2.1.0_beta25.ebuild
+++ b/app-misc/anki/anki-2.1.0_beta25.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
-PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+PYTHON_COMPAT=( python3_6 )
PYTHON_REQ_USE="sqlite"
-inherit eutils python-single-r1
+inherit eutils python-single-r1 xdg
DESCRIPTION="A spaced-repetition memory training program (flash cards)"
HOMEPAGE="https://apps.ankiweb.net"
@@ -25,6 +25,9 @@ RDEPEND="${PYTHON_DEPS}
dev-python/PyQt5[gui,svg,webkit,${PYTHON_USEDEP}]
>=dev-python/httplib2-0.7.4[${PYTHON_USEDEP}]
dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
dev-python/send2trash[${PYTHON_USEDEP}]
recording? (
media-sound/lame
@@ -37,24 +40,18 @@ RDEPEND="${PYTHON_DEPS}
)"
DEPEND=""
+PATCHES=( "${FILESDIR}"/${P}-web-folder.patch )
+
pkg_setup() {
python-single-r1_pkg_setup
}
src_prepare() {
+ default
sed -i -e "s/updates=True/updates=False/" \
aqt/profiles.py || die
}
-# Nothing to configure or compile
-src_configure() {
- :;
-}
-
-src_compile() {
- :;
-}
-
src_install() {
cp tools/runanki.system tools/anki
doicon ${PN}.png
@@ -68,4 +65,9 @@ src_install() {
# Localization files go into the anki directory:
python_moduleinto anki
python_domodule locale
+
+ # not sure if this is correct, but
+ # site-packages/aqt/mediasrv.py wants the directory
+ python_moduleinto aqt
+ python_domodule web
}
diff --git a/app-misc/anki/files/anki-2.1.0_beta25-web-folder.patch b/app-misc/anki/files/anki-2.1.0_beta25-web-folder.patch
new file mode 100644
index 000000000000..521a2ed3bd8c
--- /dev/null
+++ b/app-misc/anki/files/anki-2.1.0_beta25-web-folder.patch
@@ -0,0 +1,11 @@
+--- anki-2.1.0beta25/aqt/mediasrv.py
++++ anki-2.1.0beta25/aqt/mediasrv.py
+@@ -13,7 +13,7 @@
+ # locate web folder in source/binary distribution
+ def _getExportFolder():
+ # running from source?
+- srcFolder = os.path.join(os.path.dirname(__file__), "..")
++ srcFolder = os.path.dirname(__file__)
+ webInSrcFolder = os.path.abspath(os.path.join(srcFolder, "web"))
+ if os.path.exists(webInSrcFolder):
+ return webInSrcFolder