summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/beancounter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/beancounter')
-rw-r--r--app-misc/beancounter/Manifest1
-rw-r--r--app-misc/beancounter/beancounter-0.8.10-r1.ebuild33
-rw-r--r--app-misc/beancounter/metadata.xml11
3 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/beancounter/Manifest b/app-misc/beancounter/Manifest
new file mode 100644
index 000000000000..d3dfe1a57e5c
--- /dev/null
+++ b/app-misc/beancounter/Manifest
@@ -0,0 +1 @@
+DIST beancounter_0.8.10.tar.gz 88658 SHA256 342a29110128daf6d4dc97dc5a8275d484154d8a75362df6804c953c7cfa7bbe SHA512 6d1270f0846987fe73480e0f6b46d1c27971d70ffe2622dee9a907f852249f7d30459003cc560c95dff9e6c973a88e81c4f6f63af8f8aa278861962bba703c1b WHIRLPOOL 2108f5d8d2852d098e748ad96b4dd69c71bd47a5584243e0e9643e10bfd75276672a3cc1b932d334e6be7c81e7c4150b81c71290d3848e81096a73f585241b1d
diff --git a/app-misc/beancounter/beancounter-0.8.10-r1.ebuild b/app-misc/beancounter/beancounter-0.8.10-r1.ebuild
new file mode 100644
index 000000000000..98a4fec0fce2
--- /dev/null
+++ b/app-misc/beancounter/beancounter-0.8.10-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Finance performance calculation engine with full data acquisition and SQL support"
+HOMEPAGE="http://dirk.eddelbuettel.com/code/beancounter.html"
+SRC_URI="http://eddelbuettel.com/dirk/code/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql postgres sqlite"
+
+DEPEND="dev-perl/DateManip
+ dev-perl/Statistics-Descriptive
+ dev-perl/Finance-YahooQuote
+ dev-perl/libwww-perl
+ mysql? ( dev-perl/DBD-mysql )
+ sqlite? ( dev-perl/DBD-SQLite )
+ postgres? ( dev-perl/DBD-Pg )"
+
+RDEPEND="${DEPEND} dev-perl/DBI"
+mydoc="README example.beancounterrc beancounter_*.txt "
+
+src_install() {
+ perl-module_src_install
+ # rm unwanted READMEs
+ rm "${D}"usr/share/doc/${PF}/{README.Debian,README.non-gnu} || die
+}
diff --git a/app-misc/beancounter/metadata.xml b/app-misc/beancounter/metadata.xml
new file mode 100644
index 000000000000..5ff3359131f4
--- /dev/null
+++ b/app-misc/beancounter/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Finance performance calculation engine with data acquisition (Yahoo! Finance)
+ and SQL backend support.
+ </longdescription>
+</pkgmetadata>