summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/binwalk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/binwalk')
-rw-r--r--app-misc/binwalk/Manifest1
-rw-r--r--app-misc/binwalk/binwalk-2.0.1.ebuild43
-rw-r--r--app-misc/binwalk/files/binwalk-2.0.1-libs.patch14
-rw-r--r--app-misc/binwalk/files/binwalk-2.0.1-makefile.patch61
-rw-r--r--app-misc/binwalk/metadata.xml23
5 files changed, 142 insertions, 0 deletions
diff --git a/app-misc/binwalk/Manifest b/app-misc/binwalk/Manifest
new file mode 100644
index 000000000000..cdff1fd99390
--- /dev/null
+++ b/app-misc/binwalk/Manifest
@@ -0,0 +1 @@
+DIST binwalk-2.0.1.tar.gz 2234469 SHA256 90ee8426d71e91b62dfe4a1446c457bc7835b475b28717859e275a0494403959 SHA512 de223f61a0a212469c21b8e36d02cadc83f1cdb96a0f6114490d15d8dc12c93a86b46ef74379acb96b32b305e75ca66e940d7a18a8dc3b5036ebe8946dcca0f3 WHIRLPOOL c66ea461132417629f59e3f7562330f038263a0d522aca1db1e85f0bad5e9564d8baa27125acfb67404f0ee8045bd8da71faedcf3d2e352303ca8b0295a2767d
diff --git a/app-misc/binwalk/binwalk-2.0.1.ebuild b/app-misc/binwalk/binwalk-2.0.1.ebuild
new file mode 100644
index 000000000000..bace7a0a5b04
--- /dev/null
+++ b/app-misc/binwalk/binwalk-2.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for identifying files embedded inside firmware images"
+HOMEPAGE="https://github.com/devttys0/binwalk"
+SRC_URI="https://github.com/devttys0/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="graph"
+
+RDEPEND="
+ app-crypt/ssdeep
+ sys-apps/file[${PYTHON_USEDEP}]
+ graph? ( dev-python/pyqtgraph[opengl,${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-libs.patch
+)
+
+python_configure_all() {
+ econf --disable-bundles
+}
+
+python_compile_all() {
+ emake
+}
+
+python_install_all() {
+ local DOCS=( API.md INSTALL.md )
+ distutils-r1_python_install_all
+
+ dolib.so src/C/*/*.so
+}
diff --git a/app-misc/binwalk/files/binwalk-2.0.1-libs.patch b/app-misc/binwalk/files/binwalk-2.0.1-libs.patch
new file mode 100644
index 000000000000..5a746a4176fc
--- /dev/null
+++ b/app-misc/binwalk/files/binwalk-2.0.1-libs.patch
@@ -0,0 +1,14 @@
+Don't install C libs by default since we don't need to install them for
+every python version since they aren't linked with libpython.
+
+--- binwalk-2.0.1/setup.py
++++ binwalk-2.0.1/setup.py
+@@ -134,7 +134,7 @@
+
+ # The data files to install along with the module
+ data_dirs = ["magic", "config", "plugins", "modules", "core"]
+-install_data_files = [os.path.join("libs", "*.so")]
++install_data_files = []
+
+ for data_dir in data_dirs:
+ install_data_files.append("%s%s*" % (data_dir, os.path.sep))
diff --git a/app-misc/binwalk/files/binwalk-2.0.1-makefile.patch b/app-misc/binwalk/files/binwalk-2.0.1-makefile.patch
new file mode 100644
index 000000000000..e70f096ea6b4
--- /dev/null
+++ b/app-misc/binwalk/files/binwalk-2.0.1-makefile.patch
@@ -0,0 +1,61 @@
+Don't build python via the makefile and fix parallel make jobs.
+
+--- binwalk-2.0.1/Makefile.in
++++ binwalk-2.0.1/Makefile.in
+@@ -33,21 +33,20 @@
+ $(PYTHON) ./setup.py install $(PREFIX)
+
+ build:
+- if [ "$(BUILD_C_LIBS)" -eq "1" ]; then make -C $(SRC_C_DIR); fi
+- if [ "$(BUILD_BUNDLES)" -eq "1" ]; then make -C $(SRC_BUNDLES_DIR); fi
+- $(PYTHON) ./setup.py build
++ if [ "$(BUILD_C_LIBS)" -eq "1" ]; then $(MAKE) -C $(SRC_C_DIR); fi
++ if [ "$(BUILD_BUNDLES)" -eq "1" ]; then $(MAKE) -C $(SRC_BUNDLES_DIR); fi
+
+ deps:
+ ./deps.sh
+
+ clean:
+- if [ "$(BUILD_C_LIBS)" -eq "1" ]; then make -C $(SRC_C_DIR) clean; fi
+- if [ "$(BUILD_BUNDLES)" -eq "1" ]; then make -C $(SRC_BUNDLES_DIR) clean; fi
++ if [ "$(BUILD_C_LIBS)" -eq "1" ]; then $(MAKE) -C $(SRC_C_DIR) clean; fi
++ if [ "$(BUILD_BUNDLES)" -eq "1" ]; then $(MAKE) -C $(SRC_BUNDLES_DIR) clean; fi
+ $(PYTHON) ./setup.py clean
+
+ distclean: clean
+- if [ "$(BUILD_C_LIBS)" -eq "1" ]; then make -C $(SRC_C_DIR) distclean; fi
+- if [ "$(BUILD_BUNDLES)" -eq "1" ]; then make -C $(SRC_BUNDLES_DIR) distclean; fi
++ if [ "$(BUILD_C_LIBS)" -eq "1" ]; then $(MAKE) -C $(SRC_C_DIR) distclean; fi
++ if [ "$(BUILD_BUNDLES)" -eq "1" ]; then $(MAKE) -C $(SRC_BUNDLES_DIR) distclean; fi
+ rm -rf Makefile config.* *.cache
+
+ uninstall:
+--- binwalk-2.0.1/src/C/Makefile
++++ binwalk-2.0.1/src/C/Makefile
+@@ -3,9 +3,9 @@
+ .PHONY: all clean_libs clean distclean
+
+ all:
+- make -C miniz
++ $(MAKE) -C miniz
+ cp miniz/*.$(SOEXT) $(LIB_DIR)
+- make -C compress
++ $(MAKE) -C compress
+ cp compress/*.$(SOEXT) $(LIB_DIR)
+
+ clean_libs:
+@@ -13,10 +13,10 @@
+ rm -f $(LIB_DIR)/libcompress42.$(SOEXT)
+
+ clean: clean_libs
+- make -C miniz clean
+- make -C compress clean
++ $(MAKE) -C miniz clean
++ $(MAKE) -C compress clean
+
+ distclean: clean_libs
+- make -C miniz distclean
+- make -C compress distclean
++ $(MAKE) -C miniz distclean
++ $(MAKE) -C compress distclean
+
diff --git a/app-misc/binwalk/metadata.xml b/app-misc/binwalk/metadata.xml
new file mode 100644
index 000000000000..8edfc65b851a
--- /dev/null
+++ b/app-misc/binwalk/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <longdescription lang="en">Binwalk is a tool for searching a given binary image for embedded files.
+ Specifically, it is designed for identifying files embedded inside of firmware
+ images. Binwalk uses the libmagic library, so it is compatible with magic
+ signatures created for the Unix file utility.
+ Binwalk also includes a custom magic signature file which contains improved
+ signatures for files that are commonly found in firmware images such as
+ compressed/archived files, firmware headers, Linux kernels, bootloaders,
+ filesystems, etc.</longdescription>
+ <upstream>
+ <remote-id type="google-code">binwalk</remote-id>
+ <remote-id type="github">devttys0/binwalk</remote-id>
+ </upstream>
+ <use>
+ <flag name="graph">Enable support for generating entropy graphs</flag>
+ </use>
+</pkgmetadata>