summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-09-02 19:12:51 -0400
committerTim Harder <radhermit@gentoo.org>2016-09-02 19:12:51 -0400
commit64a7a181895035440967fae581c3ad397898b1b8 (patch)
tree2f73f3beb24f98c9b3fe3bed0042175b23071b5d /app-misc/binwalk
parentdev-python/pyqtgraph: add python3_5 support (diff)
downloadgentoo-64a7a181895035440967fae581c3ad397898b1b8.tar.gz
gentoo-64a7a181895035440967fae581c3ad397898b1b8.tar.bz2
gentoo-64a7a181895035440967fae581c3ad397898b1b8.zip
app-misc/binwalk: version bump to 2.1.1
Diffstat (limited to 'app-misc/binwalk')
-rw-r--r--app-misc/binwalk/Manifest1
-rw-r--r--app-misc/binwalk/binwalk-2.1.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/binwalk/Manifest b/app-misc/binwalk/Manifest
index cdff1fd99390..b31bff91ce31 100644
--- a/app-misc/binwalk/Manifest
+++ b/app-misc/binwalk/Manifest
@@ -1 +1,2 @@
DIST binwalk-2.0.1.tar.gz 2234469 SHA256 90ee8426d71e91b62dfe4a1446c457bc7835b475b28717859e275a0494403959 SHA512 de223f61a0a212469c21b8e36d02cadc83f1cdb96a0f6114490d15d8dc12c93a86b46ef74379acb96b32b305e75ca66e940d7a18a8dc3b5036ebe8946dcca0f3 WHIRLPOOL c66ea461132417629f59e3f7562330f038263a0d522aca1db1e85f0bad5e9564d8baa27125acfb67404f0ee8045bd8da71faedcf3d2e352303ca8b0295a2767d
+DIST binwalk-2.1.1.tar.gz 263977 SHA256 1b70a5b03489d29f60fef18008a2164974234874faab48a4f47ec53d461d284a SHA512 373e276a4d6ec845952f1091f85f953d3b0d52d561d9b74a54000ebdef85d13cafc997a4f8f76f25842db8b76fdcd1e602d4d81792a3ea01c9dea6c6ed5c2168 WHIRLPOOL 3cb8faedd02c6a4859467c285efe00e73ea3e52c48ce2b55e0344853e8a5b7884f9d15eb502ab16bba7262e38dfdb0cbcfadc7d3af4015e4357d9d2d248e6113
diff --git a/app-misc/binwalk/binwalk-2.1.1.ebuild b/app-misc/binwalk/binwalk-2.1.1.ebuild
new file mode 100644
index 000000000000..804c0b153dad
--- /dev/null
+++ b/app-misc/binwalk/binwalk-2.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for identifying files embedded inside firmware images"
+HOMEPAGE="https://github.com/devttys0/binwalk"
+SRC_URI="https://github.com/devttys0/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="graph"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/pyliblzma[${PYTHON_USEDEP}]' python2_7)
+ graph? ( dev-python/pyqtgraph[opengl,${PYTHON_USEDEP}] )
+"
+
+python_install_all() {
+ local DOCS=( API.md INSTALL.md README.md )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "binwalk has many optional dependencies to automatically"
+ elog "extract/decompress data, see INSTALL.md for more details."
+ fi
+}