summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-07-08 19:00:18 +0200
committerJohn Helmert III <ajak@gentoo.org>2022-07-08 15:13:28 -0500
commit5884d982100e6c0f44aa772397c89ddd3097e69d (patch)
tree63248278df7c150da8ae40ae7dd57f79b64a8070 /app-misc/ckb/ckb-9999.ebuild
parentmedia-sound/qtractor: bump to 0.9.27 (diff)
downloadgentoo-5884d982100e6c0f44aa772397c89ddd3097e69d.tar.gz
gentoo-5884d982100e6c0f44aa772397c89ddd3097e69d.tar.bz2
gentoo-5884d982100e6c0f44aa772397c89ddd3097e69d.zip
app-misc/ckb: version bump 0.5.0, minor improvements
* inherit udec.eclass and reload udev * build with media-sound/apulse when pulseaudio USE flag is not set Closes: https://bugs.gentoo.org/769347 Closes: https://bugs.gentoo.org/854747 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/26290 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-misc/ckb/ckb-9999.ebuild')
-rw-r--r--app-misc/ckb/ckb-9999.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/app-misc/ckb/ckb-9999.ebuild b/app-misc/ckb/ckb-9999.ebuild
new file mode 100644
index 000000000000..4629a34e2bd8
--- /dev/null
+++ b/app-misc/ckb/ckb-9999.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake udev xdg
+
+DESCRIPTION="Corsair K65/K70/K95 Driver"
+HOMEPAGE="https://github.com/ckb-next/ckb-next"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ckb-next/ckb-next.git"
+else
+ SRC_URI="https://github.com/ckb-next/ckb-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-next-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="systemd"
+
+RDEPEND="
+ dev-libs/libdbusmenu-qt
+ dev-libs/quazip:0=
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ || (
+ media-sound/pulseaudio
+ media-sound/apulse[sdk]
+ )
+ virtual/libudev:=
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_UPDATER=yes
+ -DFORCE_INIT_SYSTEM=$(usex systemd systemd openrc)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ dodoc CHANGELOG.md
+}
+
+pkg_postinst() {
+ udev_reload
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "The ckb daemon will have to be started before use:"
+ elog
+ if use systemd ; then
+ elog "# systemctl start ckb-next-daemon"
+ else
+ elog "# rc-config start ckb-next-daemon"
+ fi
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}