summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-09-09 12:22:39 -0500
committerJohn Helmert III <ajak@gentoo.org>2022-09-09 12:22:52 -0500
commit18a0c46a9c8a7a0a07437a9b0480a79ac9647b33 (patch)
tree69f58d8a2e90c7b7f31964b58cd7ca63dadc42dd /app-misc/ckb
parentapp-misc/ckb: stabilize 0.5.0 for amd64 (diff)
downloadgentoo-18a0c46a9c8a7a0a07437a9b0480a79ac9647b33.tar.gz
gentoo-18a0c46a9c8a7a0a07437a9b0480a79ac9647b33.tar.bz2
gentoo-18a0c46a9c8a7a0a07437a9b0480a79ac9647b33.zip
app-misc/ckb: drop 0.4.4-r2
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-misc/ckb')
-rw-r--r--app-misc/ckb/Manifest1
-rw-r--r--app-misc/ckb/ckb-0.4.4-r2.ebuild65
-rw-r--r--app-misc/ckb/files/ckb-0.4.4-libinput-1.2.0.patch29
-rw-r--r--app-misc/ckb/files/ckb.initd29
4 files changed, 0 insertions, 124 deletions
diff --git a/app-misc/ckb/Manifest b/app-misc/ckb/Manifest
index 2d5a0b1a5219..4cdf752d6a62 100644
--- a/app-misc/ckb/Manifest
+++ b/app-misc/ckb/Manifest
@@ -1,2 +1 @@
-DIST ckb-0.4.4.tar.gz 1593244 BLAKE2B 99476d3be98b3edac540b67b275a1ebec440f2a55d8bedd9bbdc815abd15bbeb3d035c703faa2dfdf9f4dcb70f49024c82b2990b1151b0ad5b78b741430d80f9 SHA512 b03d301a6b984957b5a3047769f25311c479f7992c59222b0ce9314b3204dac2d937c26997b97ec2ee1fdc79e3208c76a57a5c603dc1cd99ffb39fd426f58385
DIST ckb-0.5.0.tar.gz 1868880 BLAKE2B 867923f4eaf5d0e9d4ec14c5bd5952d88436c12a0d615528e083705cff7346a654dc801e743519e5482e8beb1cd28284710000e69b20032856b0e22d48792ee3 SHA512 d4e46466df4cdac7f4d4be05072592101780c94af261ec1b0bf6ec8bb1f97f892fb5da17dd91cf5f9b45fe128547cc7393c13e29843d6a7ae0de7a4688a5cdb1
diff --git a/app-misc/ckb/ckb-0.4.4-r2.ebuild b/app-misc/ckb/ckb-0.4.4-r2.ebuild
deleted file mode 100644
index c1bff1e3aab4..000000000000
--- a/app-misc/ckb/ckb-0.4.4-r2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit xdg cmake
-
-DESCRIPTION="Corsair K65/K70/K95 Driver"
-HOMEPAGE="https://github.com/ckb-next/ckb-next"
-SRC_URI="https://github.com/ckb-next/ckb-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="systemd"
-
-RDEPEND="
- dev-libs/libdbusmenu-qt
- dev-libs/quazip:0=[qt5(+)]
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- media-sound/pulseaudio
- virtual/libudev:=
- x11-libs/libX11
- x11-libs/libxcb:=
- x11-libs/xcb-util-wm"
-DEPEND="${RDEPEND}"
-BDEPEND="dev-qt/linguist-tools:5"
-
-S="${WORKDIR}/${PN}-next-${PV}"
-
-PATCHES=(
- "${FILESDIR}/${P}-libinput-1.2.0.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- -DDISABLE_UPDATER=yes
- -DFORCE_INIT_SYSTEM=$(usex systemd systemd openrc)
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- dodoc CHANGELOG.md
-
- newinitd "${FILESDIR}"/ckb.initd ckb-daemon
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "The ckb daemon will have to be started before use:"
- elog
- if use systemd ; then
- elog "# systemctl start ckb-next-daemon"
- else
- elog "# rc-service ckb start"
- fi
- fi
-}
diff --git a/app-misc/ckb/files/ckb-0.4.4-libinput-1.2.0.patch b/app-misc/ckb/files/ckb-0.4.4-libinput-1.2.0.patch
deleted file mode 100644
index 211d5e4ea01e..000000000000
--- a/app-misc/ckb/files/ckb-0.4.4-libinput-1.2.0.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From dc4dc54c5ebac7e4b455d8df35076fc044a581a7 Mon Sep 17 00:00:00 2001
-From: Tasos Sahanidis <tasos@tasossah.com>
-Date: Mon, 20 Sep 2021 14:48:18 +0300
-Subject: [PATCH] Don't enable unneeded axes in mouse device
-
-Specifically, we used to enable HI_RES wheel events without ever
-sending any. This breaks scrolling in latest libinput as it expects
-us to actually send HI_RES events.
----
- src/daemon/input_linux.c | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/src/daemon/input_linux.c b/src/daemon/input_linux.c
-index 68cc0ebb..a9ac8c8e 100644
---- a/src/daemon/input_linux.c
-+++ b/src/daemon/input_linux.c
-@@ -25,8 +25,10 @@ int uinputopen(struct uinput_user_dev* indev, int mouse){
- ioctl(fd, UI_SET_KEYBIT, i);
- // Enable mouse axes
- ioctl(fd, UI_SET_EVBIT, EV_REL);
-- for(int i = 0; i < REL_CNT; i++)
-- ioctl(fd, UI_SET_RELBIT, i);
-+ ioctl(fd, UI_SET_RELBIT, REL_X);
-+ ioctl(fd, UI_SET_RELBIT, REL_Y);
-+ ioctl(fd, UI_SET_RELBIT, REL_WHEEL);
-+ ioctl(fd, UI_SET_RELBIT, REL_HWHEEL);
- } else {
- // Enable common keyboard keys
- for(int i = KEY_ESC; i <= KEY_MEDIA; i++)
diff --git a/app-misc/ckb/files/ckb.initd b/app-misc/ckb/files/ckb.initd
deleted file mode 100644
index 76af0fd8438b..000000000000
--- a/app-misc/ckb/files/ckb.initd
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/sbin/openrc-run
-## Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-extra_started_commands="reload"
-command="/usr/bin/ckb-daemon"
-description="Controller for Corsair Keyboard Driver"
-pidfile="/run/ckb.pid"
-logfile="/var/run/ckb.log"
-
-start() {
- ebegin "Starting Corsair Keyboard Driver"
- start-stop-daemon --start --exec "${command}" --pidfile "${pidfile}" --background \
- --stdout "${logfile}" --stderr "${logfile}"
- eend $?
-}
-
-stop() {
- ebegin "Stopping Corsair Keyboard Driver"
- start-stop-daemon --stop --exec "${command}" --pidfile "${pidfile}"
- eend $?
-
-}
-
-reload() {
- stop
- sleep 3
- start
-}