summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Sartori <alberto.sartori86@gmail.com>2017-12-23 23:22:47 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-26 22:26:35 +0100
commit20c062d056d0d5a9fda5508648aa18e24f22f368 (patch)
treee70b5034222b6ff3ab5f643a2b0d214361da511f /app-misc/gcal/gcal-4.1.ebuild
parentdev-db/mongodb: amd64 stable wrt bug #643546 (diff)
downloadgentoo-20c062d056d0d5a9fda5508648aa18e24f22f368.tar.gz
gentoo-20c062d056d0d5a9fda5508648aa18e24f22f368.tar.bz2
gentoo-20c062d056d0d5a9fda5508648aa18e24f22f368.zip
app-misc/gcal: version bump to 4.1.
Closes: https://github.com/gentoo/gentoo/pull/6614
Diffstat (limited to 'app-misc/gcal/gcal-4.1.ebuild')
-rw-r--r--app-misc/gcal/gcal-4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/gcal/gcal-4.1.ebuild b/app-misc/gcal/gcal-4.1.ebuild
new file mode 100644
index 000000000000..da50405b5703
--- /dev/null
+++ b/app-misc/gcal/gcal-4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU Calendar - a replacement for cal"
+HOMEPAGE="https://www.gnu.org/software/gcal/"
+SRC_URI="mirror://gnu/gcal/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ncurses nls unicode"
+
+DEPEND="
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.17 )"
+
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS=( BUGS LIMITATIONS NEWS README THANKS TODO )
+
+src_configure() {
+ tc-export CC
+ append-cppflags -D_GNU_SOURCE
+ econf \
+ --disable-rpath \
+ $(use_enable nls) \
+ $(use_enable ncurses term) \
+ $(use_enable unicode)
+}