summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/hello
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/hello')
-rw-r--r--app-misc/hello/Manifest2
-rw-r--r--app-misc/hello/hello-2.8.ebuild28
-rw-r--r--app-misc/hello/hello-2.9.ebuild28
-rw-r--r--app-misc/hello/metadata.xml8
4 files changed, 66 insertions, 0 deletions
diff --git a/app-misc/hello/Manifest b/app-misc/hello/Manifest
new file mode 100644
index 000000000000..031bfa8bce06
--- /dev/null
+++ b/app-misc/hello/Manifest
@@ -0,0 +1,2 @@
+DIST hello-2.8.tar.gz 697483 SHA256 e6b77f81f7cf7daefad4a9f5b65de6cae9c3f13b8cfbaea8cb53bb5ea5460d73 SHA512 87fdd330fccc7d42c76df9902e21184e7976e4eb95f43dd30417030170471c34be68c37958acb6e4d3ac5f2ed7f6897730388bb6d38f5b0c06202cb8ffccb6e7 WHIRLPOOL 33f8043d8915a3ca6ce7569d2559df990d9abe17f89773230506b7ef480444fec417bbe0073c8d97d85187069b294ed4233faf81933d57c65707ab7648184b9d
+DIST hello-2.9.tar.gz 723645 SHA256 ecbb7a2214196c57ff9340aa71458e1559abd38f6d8d169666846935df191ea7 SHA512 b2be91f436d8ebbf431af7f2bb9b61453cfcd336e2745971be48c2c94d7b6ea615e05ef0526fc25f235377d3f7073e1c432c0d522891a8978252267a61aeec86 WHIRLPOOL daf3efa4571bda38f22f4cabb8707ddba883e39a097171013093fe70aa36385032331336f785a1788f51a7b7ab331c11093d88d3028893d2034aaf84eca51ef4
diff --git a/app-misc/hello/hello-2.8.ebuild b/app-misc/hello/hello-2.8.ebuild
new file mode 100644
index 000000000000..7dc4f4dba005
--- /dev/null
+++ b/app-misc/hello/hello-2.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="GNU \"Hello, world\" application"
+HOMEPAGE="http://www.gnu.org/software/hello/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+DOCS=(AUTHORS ChangeLog ChangeLog.O NEWS README THANKS TODO contrib/evolution.txt)
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ for x in contrib man doc po tests src; do
+ newdoc $x/ChangeLog ChangeLog.$x || die "newdoc failed"
+ done
+}
diff --git a/app-misc/hello/hello-2.9.ebuild b/app-misc/hello/hello-2.9.ebuild
new file mode 100644
index 000000000000..1de1a3336555
--- /dev/null
+++ b/app-misc/hello/hello-2.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="GNU \"Hello, world\" application"
+HOMEPAGE="http://www.gnu.org/software/hello/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+DOCS=(AUTHORS ChangeLog ChangeLog.O NEWS README THANKS TODO contrib/evolution.txt)
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ for x in contrib man doc po tests src; do
+ newdoc $x/ChangeLog ChangeLog.$x || die "newdoc failed"
+ done
+}
diff --git a/app-misc/hello/metadata.xml b/app-misc/hello/metadata.xml
new file mode 100644
index 000000000000..992bdd959c40
--- /dev/null
+++ b/app-misc/hello/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>jcallen@gentoo.org</email>
+ <name>Jonathan Callen</name>
+</maintainer>
+</pkgmetadata>