summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-22 02:27:39 +0000
committerSam James <sam@gentoo.org>2022-11-22 03:17:22 +0000
commitbee0d08c9993a955637119fcc33e1604050ba5eb (patch)
treed4a6e3a49971ee3b94947c25e96fbfc37830cbf0 /app-misc/interceptty
parentapp-cdr/cuecue: fix configure w/ clang 16 (diff)
downloadgentoo-bee0d08c9993a955637119fcc33e1604050ba5eb.tar.gz
gentoo-bee0d08c9993a955637119fcc33e1604050ba5eb.tar.bz2
gentoo-bee0d08c9993a955637119fcc33e1604050ba5eb.zip
app-misc/interceptty: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/interceptty')
-rw-r--r--app-misc/interceptty/interceptty-0.6-r3.ebuild (renamed from app-misc/interceptty/interceptty-0.6-r2.ebuild)9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-misc/interceptty/interceptty-0.6-r2.ebuild b/app-misc/interceptty/interceptty-0.6-r3.ebuild
index 18e316366f4c..459a172da586 100644
--- a/app-misc/interceptty/interceptty-0.6-r2.ebuild
+++ b/app-misc/interceptty/interceptty-0.6-r3.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="a program that can sit between a serial port and an application"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="http://www.suspectclass.com/~sgifford/${PN}/files/${P}.tar.gz"
@@ -10,3 +12,10 @@ SRC_URI="http://www.suspectclass.com/~sgifford/${PN}/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
+
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}