summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-13 22:22:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-13 23:04:49 +0200
commit9f931add535999062f001fe53e4e2f78e5fdec41 (patch)
tree8e8119aa2b77835ab66660ef139598b1482aacc9 /app-misc/ktoblzcheck
parentapp-misc/screen: stable 4.6.1 for hppa/sparc (diff)
downloadgentoo-9f931add535999062f001fe53e4e2f78e5fdec41.tar.gz
gentoo-9f931add535999062f001fe53e4e2f78e5fdec41.tar.bz2
gentoo-9f931add535999062f001fe53e4e2f78e5fdec41.zip
app-misc/ktoblzcheck: 1.49 version bump
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'app-misc/ktoblzcheck')
-rw-r--r--app-misc/ktoblzcheck/Manifest1
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/ktoblzcheck/Manifest b/app-misc/ktoblzcheck/Manifest
index 8b7f6495ef92..cd5a442a80d3 100644
--- a/app-misc/ktoblzcheck/Manifest
+++ b/app-misc/ktoblzcheck/Manifest
@@ -1 +1,2 @@
DIST ktoblzcheck-1.48.tar.gz 561054 BLAKE2B 559f70712050a41c07bc440ce6ebfb8a8d51053b17556b1e04d831cafb2097d61965b44ee9bcc807378923c0863136ad3b84c3d8ae59b63a21d712541e28c907 SHA512 897a98b7f39cee43f46fb34009e5d51b06fc0734f4c6e50adf888e9663114c7f927ba5b34cfe8786cb4558621828a580076cd975512a253f247b1e4ce5cfb089
+DIST ktoblzcheck-1.49.tar.gz 561501 BLAKE2B 209d88fac131f58413c27a2df1bb2a380a7517ae20050c8151c368c1a2e7675ce4d563d20e481fa7d843991a95d5edecd393dfbf601446d2657c72302fb5d7ff SHA512 da2321112a78b11ccaa938ec295275cb27a4830de0de62e7b9335f2991b9ca335f0ad10e422d9dcbd32a16effc2fc59f3cdde0fd732a639d3e6a39e141081aaa
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
new file mode 100644
index 000000000000..4465f59fe022
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ app-text/recode
+ sys-apps/grep
+ sys-apps/sed
+ virtual/awk
+ || ( net-misc/wget www-client/lynx )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf $(use_enable python)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}