summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-02 12:10:17 +0000
committerSam James <sam@gentoo.org>2021-06-02 12:21:26 +0000
commitf2f53f7355633e5fcb87f232fd4a5ef92f46b415 (patch)
tree35cfd4a807c0f4b251c82cebab6e4909d0fbfc28 /app-misc/lcd4linux
parentgames-action/gltron: add virtual/glu dep (diff)
downloadgentoo-f2f53f7355633e5fcb87f232fd4a5ef92f46b415.tar.gz
gentoo-f2f53f7355633e5fcb87f232fd4a5ef92f46b415.tar.bz2
gentoo-f2f53f7355633e5fcb87f232fd4a5ef92f46b415.zip
app-misc/lcd4linux: fix Python 3.7 usage
Missed by CI as the usage was via usex. We need to use python-utils-r1's helpers instead (but note, a pkg-config hack would've been a bit more portable if those didn't exist). Closes: https://bugs.gentoo.org/793869 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/lcd4linux')
-rw-r--r--app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild b/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild
index ef4a8ada7cf3..7e5012fe4204 100644
--- a/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild
+++ b/app-misc/lcd4linux/lcd4linux-0.11.0_pre20170527-r5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
inherit autotools flag-o-matic python-single-r1
@@ -142,7 +142,8 @@ src_prepare() {
rm ax_python_devel.m4
# Use correct python version.
- append-libs "-lpython${EPYTHON#python}$(usex python_single_target_python3_7 'm' '')"
+ # (See: bug #793869)
+ append-libs $(python_get_LIBS)
fi
eautoreconf
@@ -193,6 +194,6 @@ src_install() {
pkg_postinst() {
if [[ ! -z ${REPLACING_VERSIONS} ]]; then
- use python && einfo "Starting with that version, the python plugins uses now python3 instead if python2!"
+ use python && einfo "Starting with this version, the python plugins now uses python3 instead of python2!"
fi
}