summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-08-21 20:44:53 -0400
committerRick Farina <zerochaos@gentoo.org>2023-08-21 20:44:53 -0400
commit4ea5f19ddebee6c08ce4f69e92aadcd6305e5947 (patch)
treecb275e4b0677665f1a6c943ccd2ea489e061aaa9 /app-misc/no-more-secrets/no-more-secrets-9999.ebuild
parentmedia-radio/chirp: add deps for rr (diff)
downloadgentoo-4ea5f19ddebee6c08ce4f69e92aadcd6305e5947.tar.gz
gentoo-4ea5f19ddebee6c08ce4f69e92aadcd6305e5947.tar.bz2
gentoo-4ea5f19ddebee6c08ce4f69e92aadcd6305e5947.zip
app-misc/no-more-secrets: add 1.0.1
Also add sneakers binary Closes: https://bugs.gentoo.org/866335 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'app-misc/no-more-secrets/no-more-secrets-9999.ebuild')
-rw-r--r--app-misc/no-more-secrets/no-more-secrets-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/app-misc/no-more-secrets/no-more-secrets-9999.ebuild b/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
index 6fcda186cfdf..54a201cd898d 100644
--- a/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
+++ b/app-misc/no-more-secrets/no-more-secrets-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/bartobri/no-more-secrets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64"
fi
DESCRIPTION="Recreate decrypting text from 1992 movie 'Sneakers'"
@@ -19,11 +19,12 @@ HOMEPAGE="https://github.com/bartobri/no-more-secrets"
LICENSE="GPL-3"
SLOT=0
+BDEPEND=""
DEPEND="sys-libs/ncurses:0="
-RDEPEND="${DEPEND}"
+RDEPEND=""
PATCHES=( "${FILESDIR}"/no-more-secrets-9999-2018-10-25-respect-ldflags.patch )
src_compile() {
- CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" emake
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" emake all
}