summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Torre <torreemanuele6@gmail.com>2024-09-18 07:51:24 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-09-27 08:56:18 +0200
commitbebf04d3e8370a0fcd8356f24cb9683bda94999b (patch)
tree9c6309cc8edfadbacb00c474497edb408f5b0f5f /app-misc/remind/remind-05.00.06.ebuild
parentdev-python/beartype: Remove old (diff)
downloadgentoo-bebf04d3e8370a0fcd8356f24cb9683bda94999b.tar.gz
gentoo-bebf04d3e8370a0fcd8356f24cb9683bda94999b.tar.bz2
gentoo-bebf04d3e8370a0fcd8356f24cb9683bda94999b.zip
app-misc/remind: add 05.00.06
https://dianne.skoll.ca/pipermail/remind-fans/2024/004907.html Signed-off-by: Emanuele Torre <torreemanuele6@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38657 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-misc/remind/remind-05.00.06.ebuild')
-rw-r--r--app-misc/remind/remind-05.00.06.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-misc/remind/remind-05.00.06.ebuild b/app-misc/remind/remind-05.00.06.ebuild
new file mode 100644
index 000000000000..0e6403f27109
--- /dev/null
+++ b/app-misc/remind/remind-05.00.06.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Ridiculously functional reminder program"
+HOMEPAGE="https://dianne.skoll.ca/projects/remind/"
+SRC_URI="https://salsa.debian.org/dskoll/remind/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="tk"
+
+RDEPEND="
+ tk? ( >=dev-lang/tk-8.5 dev-tcltk/tcllib )
+"
+DEPEND="${RDEPEND}
+ dev-perl/Cairo
+ dev-perl/JSON-MaybeXS
+ dev-perl/Pango
+ virtual/perl-Getopt-Long
+"
+DOCS="docs/* examples/defs.rem"
+
+src_test() {
+ if [[ ${EUID} -eq 0 ]] ; then
+ ewarn "Testing fails if run as root. Skipping tests"
+ else
+ emake test
+ fi
+}
+
+src_install() {
+ default
+
+ if ! use tk ; then
+ rm \
+ "${D}"/usr/bin/tkremind \
+ "${D}"/usr/share/man/man1/tkremind* \
+ || die
+ fi
+
+ rm "${S}"/contrib/rem2ics-*/{Makefile,rem2ics.spec} || die
+ insinto /usr/share/${PN}
+ doins -r contrib/
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/remind.vim
+}