summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2021-12-04 13:42:47 -0800
committerJoonas Niilola <juippis@gentoo.org>2021-12-17 15:12:49 +0200
commita2ccb1496e5f8a4dcc496b5ed01d0b1d64b1fafe (patch)
treeb5597bafba9d981dacb674e57d339f8e0be16a62 /app-misc/trash-cli/trash-cli-0.21.10.24.ebuild
parentdev-lang/gnat-gpl: fix for cyclades missing (diff)
downloadgentoo-a2ccb1496e5f8a4dcc496b5ed01d0b1d64b1fafe.tar.gz
gentoo-a2ccb1496e5f8a4dcc496b5ed01d0b1d64b1fafe.tar.bz2
gentoo-a2ccb1496e5f8a4dcc496b5ed01d0b1d64b1fafe.zip
app-misc/trash-cli: Bump to 0.21.10.24
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/trash-cli/trash-cli-0.21.10.24.ebuild')
-rw-r--r--app-misc/trash-cli/trash-cli-0.21.10.24.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/trash-cli/trash-cli-0.21.10.24.ebuild b/app-misc/trash-cli/trash-cli-0.21.10.24.ebuild
new file mode 100644
index 000000000000..138286991d1c
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.21.10.24.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-lint-in-tests.patch"
+ "${FILESDIR}/${P}-fix-lint-in-trash-cli.patch"
+ "${FILESDIR}/${P}-fix-unit-tests-not-deleting-temp-directories.patch"
+ "${FILESDIR}/${P}-fix-unit-test-test_trash_empty_will_skip_unreadable.patch"
+)
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}