summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2022-04-17 01:20:41 -0700
committerJoonas Niilola <juippis@gentoo.org>2022-04-23 09:25:03 +0300
commit441cf8a767ea72ca10c06c9295bcded4a9aa336e (patch)
tree76ce42d1a8f8d23b18d3acf14eae0a5a48af5c59 /app-misc/trash-cli
parentdev-ml/sexplib: fix keywords (diff)
downloadgentoo-441cf8a767ea72ca10c06c9295bcded4a9aa336e.tar.gz
gentoo-441cf8a767ea72ca10c06c9295bcded4a9aa336e.tar.bz2
gentoo-441cf8a767ea72ca10c06c9295bcded4a9aa336e.zip
app-misc/trash-cli: add 0.22.4.16
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Closes: https://github.com/gentoo/gentoo/pull/25055 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/trash-cli')
-rw-r--r--app-misc/trash-cli/Manifest1
-rw-r--r--app-misc/trash-cli/trash-cli-0.22.4.16.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/trash-cli/Manifest b/app-misc/trash-cli/Manifest
index 7bbd8516cf4a..8a8ce9f88853 100644
--- a/app-misc/trash-cli/Manifest
+++ b/app-misc/trash-cli/Manifest
@@ -1 +1,2 @@
DIST trash-cli-0.21.10.24.tar.gz 78085 BLAKE2B 6d8f82695a94e45efd4316eb9f1a8c8f5d348774fc10cd4e5323d8dad15897f827acf343e2c1a15e1cef4eecb2ed76ab456345e359319c82bfde9b95f68f7b77 SHA512 1bf258cea7658a3968beec939d09ae088eac8898a9812e8a3aca587df7f2ad20c66f766995f8c893e4d84d0ea7db94ebb4ca7eb24982af81fa4179cc9e239fd1
+DIST trash-cli-0.22.4.16.tar.gz 78221 BLAKE2B 9eabecf5b4e787e1a413f4b05fb6c5592b4a5ec55e4a399c02c738e2ad62acaabc234217954262a79c85ad855535a2ca0d6f981b0ac86139f6c631519aeea936 SHA512 961e87ec361c405a45d02e6a4b7bf43493bca86cf3540a7235df459abd450762bcea4760acdfed0e5f276933ff0eb5b9f426ae0eecfde3e5830a8699fa99a19f
diff --git a/app-misc/trash-cli/trash-cli-0.22.4.16.ebuild b/app-misc/trash-cli/trash-cli-0.22.4.16.ebuild
new file mode 100644
index 000000000000..641302d9ab3e
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.22.4.16.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}