summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-28 06:41:24 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-28 06:47:46 -0800
commit7e16982e4fdc7a725f945b21a524ccafb7a26ced (patch)
tree1a8e8806ce98688179739aa714838a86d36fc874 /app-misc/tty-clock/tty-clock-2.3.ebuild
parentsci-mathematics/cadical: new package; add version 1.5.2 (diff)
downloadgentoo-7e16982e4fdc7a725f945b21a524ccafb7a26ced.tar.gz
gentoo-7e16982e4fdc7a725f945b21a524ccafb7a26ced.tar.bz2
gentoo-7e16982e4fdc7a725f945b21a524ccafb7a26ced.zip
app-misc/tty-clock: initial import
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-misc/tty-clock/tty-clock-2.3.ebuild')
-rw-r--r--app-misc/tty-clock/tty-clock-2.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/tty-clock/tty-clock-2.3.ebuild b/app-misc/tty-clock/tty-clock-2.3.ebuild
new file mode 100644
index 000000000000..4118f7d9021e
--- /dev/null
+++ b/app-misc/tty-clock/tty-clock-2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays a simple digital clock on the terminal"
+HOMEPAGE="https://github.com/xorg62/tty-clock"
+SRC_URI="https://github.com/xorg62/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+DEPEND="sys-libs/ncurses:=[unicode(+)]"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ # makefile does something with ncurses-config and calls old version
+ # let's just build it manually
+ $(tc-getCC) -Wall ${CFLAGS} ${PN//-/}.c \
+ $($(tc-getPKG_CONFIG) --libs ncursesw) \
+ -o ${PN} ${LDFLAGS} || die "Failed to build ${PN}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ einstalldocs
+}