summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Chren <dev.rindeal@gmail.com>2016-04-28 15:03:45 +0200
committerTim Harder <radhermit@gentoo.org>2016-04-29 23:53:47 -0400
commit251e0d08bf9303fbbd2ccb66b550def65f609db5 (patch)
treef0a2ad4e0d63d7c63cda0374a4d417696fc9bdec /app-misc
parentnet-analyzer/icinga2: better url (diff)
downloadgentoo-251e0d08bf9303fbbd2ccb66b550def65f609db5.tar.gz
gentoo-251e0d08bf9303fbbd2ccb66b550def65f609db5.tar.bz2
gentoo-251e0d08bf9303fbbd2ccb66b550def65f609db5.zip
app-misc/jq: fix buffer overflow (bug #580606) and other updates
- add upstream metadata - add arm architecture - refactor econf args to an array - move DOCS and PATCHES to their appropriate functions - replace custom find with prune_libtool_files() Gentoo-Bug: 580606
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/jq/files/jq-1.5-heap_buffer_overflow_in_tokenadd.patch34
-rw-r--r--app-misc/jq/jq-1.5-r2.ebuild60
2 files changed, 94 insertions, 0 deletions
diff --git a/app-misc/jq/files/jq-1.5-heap_buffer_overflow_in_tokenadd.patch b/app-misc/jq/files/jq-1.5-heap_buffer_overflow_in_tokenadd.patch
new file mode 100644
index 000000000000..edb07d8388b5
--- /dev/null
+++ b/app-misc/jq/files/jq-1.5-heap_buffer_overflow_in_tokenadd.patch
@@ -0,0 +1,34 @@
+From 8eb1367ca44e772963e704a700ef72ae2e12babd Mon Sep 17 00:00:00 2001
+From: Nicolas Williams <nico@cryptonector.com>
+Date: Sat, 24 Oct 2015 17:24:57 -0500
+Subject: [PATCH] Heap buffer overflow in tokenadd() (fix #105)
+
+This was an off-by one: the NUL terminator byte was not allocated on
+resize. This was triggered by JSON-encoded numbers longer than 256
+bytes.
+---
+ src/jv_parse.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/jv_parse.c b/src/jv_parse.c
+index 3102ed4..84245b8 100644
+--- a/jv_parse.c
++++ b/jv_parse.c
+@@ -383,7 +383,7 @@ static pfunc stream_token(struct jv_parser* p, char ch) {
+
+ static void tokenadd(struct jv_parser* p, char c) {
+ assert(p->tokenpos <= p->tokenlen);
+- if (p->tokenpos == p->tokenlen) {
++ if (p->tokenpos >= (p->tokenlen - 1)) {
+ p->tokenlen = p->tokenlen*2 + 256;
+ p->tokenbuf = jv_mem_realloc(p->tokenbuf, p->tokenlen);
+ }
+@@ -485,7 +485,7 @@ static pfunc check_literal(struct jv_parser* p) {
+ TRY(value(p, v));
+ } else {
+ // FIXME: better parser
+- p->tokenbuf[p->tokenpos] = 0; // FIXME: invalid
++ p->tokenbuf[p->tokenpos] = 0;
+ char* end = 0;
+ double d = jvp_strtod(&p->dtoa, p->tokenbuf, &end);
+ if (end == 0 || *end != 0)
diff --git a/app-misc/jq/jq-1.5-r2.ebuild b/app-misc/jq/jq-1.5-r2.ebuild
new file mode 100644
index 000000000000..df58a521ae1e
--- /dev/null
+++ b/app-misc/jq/jq-1.5-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="A lightweight and flexible command-line JSON processor"
+HOMEPAGE="https://stedolan.github.com/jq/"
+SRC_URI="https://github.com/stedolan/jq/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="MIT CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="oniguruma static-libs test"
+
+DEPEND="
+ >=sys-devel/bison-3.0
+ sys-devel/flex
+ oniguruma? ( dev-libs/oniguruma[static-libs?] )
+ test? ( dev-util/valgrind )
+"
+RDEPEND="
+ !static-libs? (
+ oniguruma? ( dev-libs/oniguruma[static-libs?] )
+ )
+"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-1.5-dynamic-link.patch
+ "${FILESDIR}"/${PN}-1.5-remove-automagic-dep-on-oniguruma.patch
+ "${FILESDIR}"/${PN}-1.5-heap_buffer_overflow_in_tokenadd.patch
+ )
+
+ sed -i '/^dist_doc_DATA/d' Makefile.am || die
+ sed -i -r "s:(m4_define\(\[jq_version\],) .+\):\1 \[${PV}\]):" \
+ configure.ac || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ # don't try to rebuild docs
+ --disable-docs
+ $(use_enable static-libs static)
+ $(use_with oniguruma)
+ )
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS README )
+ default
+
+ use static-libs || prune_libtool_files
+}