summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 20:31:51 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:04 +0100
commit7735d48818ae070dddd907dc1bdaac3ac601e80c (patch)
tree8a50706de41408d0f20432fb1f4dd5c2b062b895 /app-misc
parentapp-misc/ddate: drop 0.2.2_p20160627 (diff)
downloadgentoo-7735d48818ae070dddd907dc1bdaac3ac601e80c.tar.gz
gentoo-7735d48818ae070dddd907dc1bdaac3ac601e80c.tar.bz2
gentoo-7735d48818ae070dddd907dc1bdaac3ac601e80c.zip
app-misc/fr24feed: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fr24feed/fr24feed-1.0.25_p3-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/fr24feed/fr24feed-1.0.25_p3-r1.ebuild b/app-misc/fr24feed/fr24feed-1.0.25_p3-r1.ebuild
new file mode 100644
index 000000000000..fec2d65d159d
--- /dev/null
+++ b/app-misc/fr24feed/fr24feed-1.0.25_p3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV/-/_}"
+MY_PV="${MY_PV/_p/-}"
+MY_P="${PN}_${MY_PV}"
+
+DESCRIPTION="Flightradar24 data sharing software"
+HOMEPAGE="https://www.flightradar24.com/share-your-data"
+SRC_URI="
+ amd64? ( https://repo-feed.flightradar24.com/linux_x86_64_binaries/${MY_P}_amd64.tgz )
+ x86? ( https://repo-feed.flightradar24.com/linux_x86_binaries/${MY_P}_i386.tgz )
+"
+S="${WORKDIR}"
+
+LICENSE="Flightradar24"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+
+RDEPEND="
+ net-wireless/dump1090
+ virtual/libusb:1
+"
+
+RESTRICT="bindist mirror"
+
+QA_PREBUILT="usr/bin/fr24feed"
+
+src_install() {
+ dobin fr24feed_$(usex amd64 'amd64' 'i386')/fr24feed
+
+ insinto /etc
+ doins "${FILESDIR}"/fr24feed.ini
+
+ newinitd "${FILESDIR}"/fr24feed.initd fr24feed
+ newconfd "${FILESDIR}"/fr24feed.confd fr24feed
+}
+
+pkg_postinst() {
+ elog "Please run '/usr/bin/fr24feed --signup', to register yourself as a data feeder."
+}