summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-21 20:46:03 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-21 20:47:27 +0100
commit8f17ca9ca7749834114471aad29a34f71ac70428 (patch)
tree0bcb2ad4cf06baf02de1b0bf692f39c5314e27a6 /app-misc
parentapp-misc/ddcutil: add version 1.2.2 (diff)
downloadgentoo-8f17ca9ca7749834114471aad29a34f71ac70428.tar.gz
gentoo-8f17ca9ca7749834114471aad29a34f71ac70428.tar.bz2
gentoo-8f17ca9ca7749834114471aad29a34f71ac70428.zip
app-misc/ddcui: add version 0.2.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ddcui/Manifest1
-rw-r--r--app-misc/ddcui/ddcui-0.2.1.ebuild35
-rw-r--r--app-misc/ddcui/files/ddcui-0.2.1-build.patch13
3 files changed, 49 insertions, 0 deletions
diff --git a/app-misc/ddcui/Manifest b/app-misc/ddcui/Manifest
index 52577bfa1be8..bf8736d49740 100644
--- a/app-misc/ddcui/Manifest
+++ b/app-misc/ddcui/Manifest
@@ -1,2 +1,3 @@
DIST ddcui-0.1.2.tar.gz 126766 BLAKE2B 85317b68bbd7e3e5b780ad2ba45888049f9ca70695ccfeb5d0acc2f2c8db11ee97438aa53240671f908caffd45b12a488593cd82b41c8e1acbad38f97d560ab4 SHA512 008033f23cf1dccb69b503b2f8950518e771bd4892b2df912186712859e6e66f724019beb5941d49452ae9a6080ce2730a1e11ec201931a31b3ab4735c03c724
DIST ddcui-0.2.0.tar.gz 598886 BLAKE2B d44e7b2226ca815c3d468a69f805b4be6359b447095e2688f98a5bde106d348dc2cbc80c31fc1de47f1bf0ebc7db4fae63e3e4f1501c10a6a7bb0c06718ad3cd SHA512 0509b2adae1b4a5c9cac3f3d598327085f183ada0fa8ef2ae85c1220704bdc50583fdc370f809b52d62eaeeae6a30146d63435ef2134a6467360eb6f90e64191
+DIST ddcui-0.2.1.tar.gz 601220 BLAKE2B 18af4ee4db741a612565260ed812f7274695472e9dc6e32c6670efcbdaeafcac9b0b45e44d02188d23e0f379f57b062270ecad58bdcfa8e8c2bf99c2775b1dfe SHA512 0df363dbf17750e3920e0afc5fc29b42271bbf06dcf52cddf46f3660155c0954ee39e8e356e9caebe1a6a679ab0b3a4ebb2e501a9bb9ac2cd47da3f522fb3169
diff --git a/app-misc/ddcui/ddcui-0.2.1.ebuild b/app-misc/ddcui/ddcui-0.2.1.ebuild
new file mode 100644
index 000000000000..41f27dbaf941
--- /dev/null
+++ b/app-misc/ddcui/ddcui-0.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Graphical user interface for ddcutil - control monitor settings"
+HOMEPAGE="https://www.ddcutil.com/ddcui_main/"
+SRC_URI="https://github.com/rockowitz/ddcui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ dev-libs/glib
+ >=app-misc/ddcutil-1.2.0:0/4
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qthelp:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
+src_prepare() {
+ # move docs to correct dir
+ sed -i -e "s%share/doc/ddcui%share/doc/${PF}%g" CMakeLists.txt || die
+ cmake_src_prepare
+}
diff --git a/app-misc/ddcui/files/ddcui-0.2.1-build.patch b/app-misc/ddcui/files/ddcui-0.2.1-build.patch
new file mode 100644
index 000000000000..e27018206c1d
--- /dev/null
+++ b/app-misc/ddcui/files/ddcui-0.2.1-build.patch
@@ -0,0 +1,13 @@
+diff --git a/src/feature_value_widgets/value_special_widget_x62.cpp b/src/feature_value_widgets/value_special_widget_x62.cpp
+index 1fb8118..e7169d2 100644
+--- a/src/feature_value_widgets/value_special_widget_x62.cpp
++++ b/src/feature_value_widgets/value_special_widget_x62.cpp
+@@ -185,7 +185,7 @@ void ValueSpecialWidgetX62::combobox_activated(int index) {
+ bool debug = false;
+ debug = debug || debugWidget;
+ TRACEMCF(debug, "feature 0x%02x, index=%d", _featureCode, index);
+- assert(_cb->currentIndex == index);
++ assert(_cb->currentIndex() == index);
+
+ // QVariant qv = _cb->itemData(ndx);
+ // uint i = qv.toUInt();