summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Kletzander <nert.pinx@gmail.com>2022-01-14 10:43:51 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-02-11 16:56:44 +0200
commita962b92c468ea99b30da4d9a96edab90501eafae (patch)
tree76ce6a9ad5dc9b06ee822e5cd025647a048b3da8 /app-misc
parentdev-util/tup: update HOMEPAGE, add missing BDEPEND for 0.7.11 (diff)
downloadgentoo-a962b92c468ea99b30da4d9a96edab90501eafae.tar.gz
gentoo-a962b92c468ea99b30da4d9a96edab90501eafae.tar.bz2
gentoo-a962b92c468ea99b30da4d9a96edab90501eafae.zip
app-misc/hivex: Do not depend hardly on ruby
The ruby-ng eclass exports src_prepare function and it should be only called conditionally just like all the other functions, so add a better src_prepare function as otherwise the build can fail if no compatible ruby target is selected in RUBY_TARGETS even if hivex is emerging with -ruby. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Martin Kletzander <nert.pinx@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23790 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/hivex/hivex-1.3.20.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-misc/hivex/hivex-1.3.20.ebuild b/app-misc/hivex/hivex-1.3.20.ebuild
index 7c8d10963bbb..60d911612b9d 100644
--- a/app-misc/hivex/hivex-1.3.20.ebuild
+++ b/app-misc/hivex/hivex-1.3.20.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -65,6 +65,12 @@ src_unpack() {
cp -prlP "${WORKDIR}/${P}" "${WORKDIR}"/all || die
}
+src_prepare() {
+ default
+ use perl && perl-module_src_prepare
+ use ruby && ruby-ng_src_prepare
+}
+
src_configure() {
use ruby && ruby-ng_src_configure