summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 20:47:39 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:14 +0100
commitad4e721c0f61490944ead75c15c471366768822d (patch)
tree6ebc9ad29a200fe4f86433f201c6d638ff6fc890 /app-misc
parentapp-misc/rioutil: drop 1.5.4 (diff)
downloadgentoo-ad4e721c0f61490944ead75c15c471366768822d.tar.gz
gentoo-ad4e721c0f61490944ead75c15c471366768822d.tar.bz2
gentoo-ad4e721c0f61490944ead75c15c471366768822d.zip
app-misc/transfolio: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/transfolio/transfolio-1.0.1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/transfolio/transfolio-1.0.1-r2.ebuild b/app-misc/transfolio/transfolio-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..20b22084f589
--- /dev/null
+++ b/app-misc/transfolio/transfolio-1.0.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Enables data transfer between the PC and the Atari Portfolio"
+HOMEPAGE="http://leute.server.de/peichl/"
+SRC_URI="http://leute.server.de/peichl/transfolio.zip -> ${P}.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+BDEPEND="app-arch/unzip"
+
+src_prepare() {
+ default
+
+ # Respect users CC, CFLAGS, LDFLAGS and disable striping
+ sed -e 's/cc/${CC}/' -e 's/-O2/${CFLAGS} ${LDFLAGS}/' -e '/strip/d' -i Makefile || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin transfolio
+
+ einstalldocs
+}