summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 20:43:05 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:11 +0100
commitbf93fa53782bfb64f4e0ebe494fc33ae862f9a17 (patch)
treea1616f6cd229c36b77a653d4e1ecdd112210f675 /app-misc
parentapp-misc/lcdproc: add 0.5.9_p20211220 (diff)
downloadgentoo-bf93fa53782bfb64f4e0ebe494fc33ae862f9a17.tar.gz
gentoo-bf93fa53782bfb64f4e0ebe494fc33ae862f9a17.tar.bz2
gentoo-bf93fa53782bfb64f4e0ebe494fc33ae862f9a17.zip
app-misc/logiops: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/logiops/logiops-0.2.3-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/logiops/logiops-0.2.3-r1.ebuild b/app-misc/logiops/logiops-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..55057eb6fb40
--- /dev/null
+++ b/app-misc/logiops/logiops-0.2.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake linux-info
+
+DESCRIPTION="An unofficial userspace driver for HID++ Logitech devices"
+HOMEPAGE="https://github.com/PixlOne/logiops"
+SRC_URI="https://github.com/PixlOne/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+DEPEND="
+ dev-libs/libconfig:=[cxx]
+ dev-libs/libevdev
+ virtual/libudev
+ systemd? ( sys-apps/systemd )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "TESTED.md" )
+
+pkg_pretend() {
+ local CHECK_CONFIG="~HID_LOGITECH ~HID_LOGITECH_HIDPP"
+
+ check_extra_config
+}
+
+src_install() {
+ default
+
+ cmake_src_install
+
+ insinto /etc
+ newins logid.example.cfg logid.cfg
+
+ newinitd "${FILESDIR}"/logid.initd logid
+}
+
+pkg_postinst() {
+ einfo "An example config file has been installed as /etc/logid.cfg."
+ einfo "See https://github.com/PixlOne/logiops/wiki/Configuration for more information."
+}