summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-01-29 22:32:46 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-29 22:33:08 +0100
commitc24a30d6ce67243dd8589592d15b3a0eba3a0bf9 (patch)
treed65f4f01920256c5c5746bae9ae4b8b233f7385f /app-misc
parentdev-libs/libnl: Replace in6.h patch with complete upstream patch. (diff)
downloadgentoo-c24a30d6ce67243dd8589592d15b3a0eba3a0bf9.tar.gz
gentoo-c24a30d6ce67243dd8589592d15b3a0eba3a0bf9.tar.bz2
gentoo-c24a30d6ce67243dd8589592d15b3a0eba3a0bf9.zip
app-misc/todo: new package.
todo is a CLI-based TODO list manager written in Bash. Gentoo-Bug: https://bugs.gentoo.org/149233 Package-Manager: portage-2.3.3
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/todo/Manifest1
-rw-r--r--app-misc/todo/metadata.xml8
-rw-r--r--app-misc/todo/todo-2.10.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/todo/Manifest b/app-misc/todo/Manifest
new file mode 100644
index 000000000000..1a302b9e9c61
--- /dev/null
+++ b/app-misc/todo/Manifest
@@ -0,0 +1 @@
+DIST todo-2.10.tar.gz 56509 SHA256 55b6b86a970c25efcd05b24b37e8141bab623ddfa681638d49fd6fd6907eda2c SHA512 b14d9d13948836d971f72b941770e8e2c59d171d35f074205900619c5c3efd7ca0a482887046c1865890afb6595fe27c69677c54ea5824163d291e16fa5329d3 WHIRLPOOL 4282bad14c1ffac5642577ed9de4bec273eb56be28b9a019e06b11d181b56bef708167eef31fafaec607a502edd1f4edf82b1d5ba0eb4df4c27e01944f9795d6
diff --git a/app-misc/todo/metadata.xml b/app-misc/todo/metadata.xml
new file mode 100644
index 000000000000..58c1077b82e4
--- /dev/null
+++ b/app-misc/todo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/todo/todo-2.10.ebuild b/app-misc/todo/todo-2.10.ebuild
new file mode 100644
index 000000000000..c8eefae79b64
--- /dev/null
+++ b/app-misc/todo/todo-2.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="A CLI-based TODO list manager"
+HOMEPAGE="http://todotxt.com/"
+SRC_URI="https://github.com/ginatrapani/${PN}.txt-cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="app-shells/bash"
+
+S="${WORKDIR}/${PN}.txt-cli-${PV}"
+
+DOCS=( README.textile CONTRIBUTING.md LICENSE todo.cfg )
+
+src_test() {
+ make test || die "tests failed"
+}
+
+src_install() {
+ newbin "${PN}.sh" "${PN}"
+ newbashcomp "${PN}_completion" "${PN}"
+ einstalldocs
+}