summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-01 21:26:28 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-01 21:56:49 -0400
commitd5b66c5fc3651bebeb0925789789e855f651852f (patch)
treeb8797cbf25313d841a183eb0b2f9f8bec4e112e0 /app-misc
parentwww-apps/jellyfin: add 10.8.3 (diff)
downloadgentoo-d5b66c5fc3651bebeb0925789789e855f651852f.tar.gz
gentoo-d5b66c5fc3651bebeb0925789789e855f651852f.tar.bz2
gentoo-d5b66c5fc3651bebeb0925789789e855f651852f.zip
app-misc/countrycodes: Version bump to 1.0.6
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/countrycodes/Manifest1
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.6.ebuild29
-rw-r--r--app-misc/countrycodes/files/1.0.6-Makefile.patch35
3 files changed, 65 insertions, 0 deletions
diff --git a/app-misc/countrycodes/Manifest b/app-misc/countrycodes/Manifest
index aeb223a8e905..6820a770e307 100644
--- a/app-misc/countrycodes/Manifest
+++ b/app-misc/countrycodes/Manifest
@@ -1 +1,2 @@
DIST countrycodes-1.0.5.tar.gz 18621 BLAKE2B 1f2e1fb0f96d1388687929895c310e1e93c320f4d3f3f4cfe19c50d2ab850bafcefb5e13cfdaed546237ae5873eb95ae574ac47c0048bc2fa37c96158b5082fe SHA512 d62beaaccdbc8f7e14f3edf0044aeeef6375a3deffc0e4246a49fb8209ed7256208c878f811950c5c3bfda729988a46c173aecec72ee66e8843932d97064f035
+DIST countrycodes-1.0.6.tar.gz 18834 BLAKE2B b5e0806618da0dd740a890b9c4d369cf2c44182515ec91aaa08a5e19da447635fb8536611a278ffcc419b506efa07df7e71bf5d520895a059c4aaa6e0cbc9b48 SHA512 be069593f60f785ef4d2e107340b941902a9c45d81ed04f8518a78f2be610ffdd1675da3da1d07271fc7ab736aabdd9f92f060d132e7b7b41310f1b653c53244
diff --git a/app-misc/countrycodes/countrycodes-1.0.6.ebuild b/app-misc/countrycodes/countrycodes-1.0.6.ebuild
new file mode 100644
index 000000000000..01499421f229
--- /dev/null
+++ b/app-misc/countrycodes/countrycodes-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An ISO 3166 country code finder"
+HOMEPAGE="https://sourceforge.net/projects/countrycodes/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+PATCHES=( "${FILESDIR}"/${PV}-Makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ prefix="${ED}"/usr \
+ mandir="${ED}"/usr/share/man install
+ dosym iso3166 /usr/bin/countrycodes
+ dosym iso3166.1 /usr/share/man/man1/countrycodes
+ dodoc README
+}
diff --git a/app-misc/countrycodes/files/1.0.6-Makefile.patch b/app-misc/countrycodes/files/1.0.6-Makefile.patch
new file mode 100644
index 000000000000..051c02946230
--- /dev/null
+++ b/app-misc/countrycodes/files/1.0.6-Makefile.patch
@@ -0,0 +1,35 @@
+diff --git a/Makefile b/Makefile
+index b6e1323..b11a453 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,10 +23,9 @@ BINMODE=755
+ LOGDIRMODE=700
+
+ # Compiler to use
+-CC=gcc
+
+ # Compiler warnings
+-WARNINGS= -pedantic -Wall
++CFLAGS += -pedantic -Wall
+
+ # Compiler flags
+ CCOPTS = -O2 -fomit-frame-pointer
+@@ -58,7 +57,7 @@ PROGRAM = iso3166
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(ISO3166OBJ)
+- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(ISO3166OBJ) -o $@
+
+ clean:
+ $(RM) $(ISO3166OBJ) core defines.h $(PROGRAM)
+@@ -79,9 +78,6 @@ uninstall:
+ $(RM) ${bindir}/$(PROGRAM)
+ $(RM) ${mandir}/iso3166.1
+
+-.c.o:
+- $(CC) $(CCOPTS) $(WARNINGS) -c $<
+-
+ $(ISO3166OBJ): common.h defines.h protos.h tables.h
+
+ defines.h: