summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2021-06-06 23:01:37 +0100
committerPatrick McLean <chutzpah@gentoo.org>2021-06-08 16:13:42 -0700
commite21bdc23df6be5ac3d1f907b815d2d837886172a (patch)
tree4051e4d50a65ad2fcf1f67ad180643bfac4c4145 /app-misc
parentdev-python/google-api-python-client: Bump to 2.8.0 (diff)
downloadgentoo-e21bdc23df6be5ac3d1f907b815d2d837886172a.tar.gz
gentoo-e21bdc23df6be5ac3d1f907b815d2d837886172a.tar.bz2
gentoo-e21bdc23df6be5ac3d1f907b815d2d837886172a.zip
app-misc/OpenRGB: version 0.6
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/OpenRGB/Manifest1
-rw-r--r--app-misc/OpenRGB/OpenRGB-0.6.ebuild57
-rw-r--r--app-misc/OpenRGB/files/OpenRGB-0.6-pkgconf.patch11
3 files changed, 69 insertions, 0 deletions
diff --git a/app-misc/OpenRGB/Manifest b/app-misc/OpenRGB/Manifest
index c2ca31416fa..a27eaef18df 100644
--- a/app-misc/OpenRGB/Manifest
+++ b/app-misc/OpenRGB/Manifest
@@ -1,2 +1,3 @@
DIST OpenRGB-release_0.4.tar.bz2 2195819 BLAKE2B 6416e143707e5ae48d0f26d205e1cc27571299d7d4b8483d18cc03db237d71ebc3574973fc1540dacc24662c536888e575e89db417e52dc9672d412fe41c540b SHA512 9ecdf0a0aec5916b1c705c1ad0bd567f46f9b0a4409211cb195ec7a4bfbc95c80bde13798839d23e867ed613cb34c6e9629da4aac942490f58ca9528f5f0a8bd
DIST OpenRGB-release_0.5.tar.bz2 24183948 BLAKE2B c3e6eaab2224f97287a454375486cdacc6814f35fe6752271293d30110d066998d95a901224929cdec7f57a3983fa9d8f5dc488a2ccb6d128df36fac6bc4582a SHA512 d0bd69de94e7e94b9972c07851602d8437b4485d02e83e2fe84f21292acbeef32624ec82d5cb79de85a4dfec35431c469b124b0cc41cf1f741e6e52803dd82eb
+DIST OpenRGB-release_0.6.tar.bz2 24301305 BLAKE2B 20d8f8f7a3189fd5f94b008b11c869d2a8584dc038322e4ac8649c7b57172637133dd18c05ed8eaa6907ba7c097280727a9e7ce2e676250146044bbc2d66921e SHA512 9eb090e1cab121308f3adea8c50feb819a19cb52feff29e45ec24dfbb37013421f53d2ac614496781af1ef4e612dd41c1abafec509430df7d0715aba59ee5a32
diff --git a/app-misc/OpenRGB/OpenRGB-0.6.ebuild b/app-misc/OpenRGB/OpenRGB-0.6.ebuild
new file mode 100644
index 00000000000..c356d7aff6f
--- /dev/null
+++ b/app-misc/OpenRGB/OpenRGB-0.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=${EGIT_REPO_URI:-"https://gitlab.com/CalcProgrammer1/OpenRGB"}
+else
+ SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
+ S="${WORKDIR}/OpenRGB-release_${PV}"
+ KEYWORDS="~amd64 ~x86"
+ PATCHES=(
+ "${FILESDIR}"/OpenRGB-0.5-build-system.patch
+ )
+fi
+
+DESCRIPTION="Open source RGB lighting control that doesn't depend on manufacturer software"
+HOMEPAGE="https://gitlab.com/CalcProgrammer1/OpenRGB/"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/hidapi:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ virtual/libusb:1
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES+=(
+ "${FILESDIR}"/OpenRGB-0.6-pkgconf.patch
+)
+
+src_prepare() {
+ default
+ rm -r dependencies/{hidapi,libusb,json}* || die
+}
+
+src_configure() {
+ eqmake5 INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+
+ dodoc README.md OpenRGB.patch
+}
diff --git a/app-misc/OpenRGB/files/OpenRGB-0.6-pkgconf.patch b/app-misc/OpenRGB/files/OpenRGB-0.6-pkgconf.patch
new file mode 100644
index 00000000000..380b1091d22
--- /dev/null
+++ b/app-misc/OpenRGB/files/OpenRGB-0.6-pkgconf.patch
@@ -0,0 +1,11 @@
+--- a/OpenRGB.pro 2021-06-06 22:51:12.022561718 +0100
++++ b/OpenRGB.pro 2021-06-06 22:51:24.466105358 +0100
+@@ -837,7 +837,7 @@ unix:!macx {
+ # hidapi-hidraw >= 0.10.1 supports USAGE/USAGE_PAGE #
+ # Define USE_HID_USAGE if hidapi-hidraw supports it #
+ #---------------------------------------------------------------------------------------#
+- HIDAPI_HIDRAW_VERSION = $$system(pkgconf --modversion hidapi-hidraw)
++ HIDAPI_HIDRAW_VERSION = $$system(pkg-config --modversion hidapi-hidraw)
+ if(versionAtLeast(HIDAPI_HIDRAW_VERSION, "0.10.1")) {
+ DEFINES += USE_HID_USAGE
+ }