summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-25 15:02:40 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-25 15:04:06 -0400
commitfd058e831e7e754bfa424ca309cb52ef64647eb8 (patch)
treed459a60a5f2b9416a6e554e262344f5e111c17c9 /app-mobilephone/dfu-util
parentnet-libs/nghttp2: Removed old. (diff)
downloadgentoo-fd058e831e7e754bfa424ca309cb52ef64647eb8.tar.gz
gentoo-fd058e831e7e754bfa424ca309cb52ef64647eb8.tar.bz2
gentoo-fd058e831e7e754bfa424ca309cb52ef64647eb8.zip
app-mobilephone/dfu-util: version bump to 0.9
Diffstat (limited to 'app-mobilephone/dfu-util')
-rw-r--r--app-mobilephone/dfu-util/Manifest1
-rw-r--r--app-mobilephone/dfu-util/dfu-util-0.9.ebuild28
-rw-r--r--app-mobilephone/dfu-util/dfu-util-9999.ebuild24
-rw-r--r--app-mobilephone/dfu-util/metadata.xml5
4 files changed, 40 insertions, 18 deletions
diff --git a/app-mobilephone/dfu-util/Manifest b/app-mobilephone/dfu-util/Manifest
index e979d4f68838..a5049ac9d141 100644
--- a/app-mobilephone/dfu-util/Manifest
+++ b/app-mobilephone/dfu-util/Manifest
@@ -1 +1,2 @@
DIST dfu-util-0.7.tar.gz 125356 SHA256 f52a2a5489fbf9f3204a6ada05e0b47ee322e19d81c712e0c58a332d80ec3eab SHA512 df5227655d2d39e8c0323e87a97e38e86481b12ef91528045e8a5a2009a3fe3b6f09acfed8612756c3895253075dbe958aeaf1c9c50c2266efeb22b88d3842e2 WHIRLPOOL 9c74edd96e8f85dd86e0c8a5862a1277cd74b0821b73823f1ecc86e046fdc5cc6ac5fa45cd67de6a65d73ad935b58d0c4109362c2650ac233e18d6727e0ac944
+DIST dfu-util-0.9.tar.gz 138397 SHA256 36428c6a6cb3088cad5a3592933385253da5f29f2effa61518ee5991ea38f833 SHA512 caa7148b7a9004e2b1f7bc4f1a26b48abfe311743bc0eeed1ab57459910371affc39b6fe7e74b7cac6ca9de41a9901b7a970253ca92d7d66d5008f8a11d2c952 WHIRLPOOL 5eff75635854bb77ffde458b7c6c3dbe7d366207eaf340a5a6a8db132d34ca86d545c87a38c97c1c9bf109c2218b2499aa4c3dce374da5def952a39c7d893391
diff --git a/app-mobilephone/dfu-util/dfu-util-0.9.ebuild b/app-mobilephone/dfu-util/dfu-util-0.9.ebuild
new file mode 100644
index 000000000000..d5ccd44212ed
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-0.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
+ inherit autotools git-r3
+else
+ SRC_URI="http://dfu-util.gnumonks.org/releases/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://dfu-util.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
diff --git a/app-mobilephone/dfu-util/dfu-util-9999.ebuild b/app-mobilephone/dfu-util/dfu-util-9999.ebuild
index 50df59c681f6..d5ccd44212ed 100644
--- a/app-mobilephone/dfu-util/dfu-util-9999.ebuild
+++ b/app-mobilephone/dfu-util/dfu-util-9999.ebuild
@@ -1,38 +1,28 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.openezx.org/dfu-util.git"
- inherit autotools git-2
- SRC_URI=""
- #KEYWORDS=""
+ EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
+ inherit autotools git-r3
else
SRC_URI="http://dfu-util.gnumonks.org/releases/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
-HOMEPAGE="http://wiki.openmoko.org/wiki/Dfu-util"
+HOMEPAGE="http://dfu-util.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
RDEPEND="virtual/libusb:1"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
- eautoreconf
- fi
- sed -i '/^bin_PROGRAMS/s:dfu-util_static[^ ]*::' src/Makefile.in
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog README TODO
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
}
diff --git a/app-mobilephone/dfu-util/metadata.xml b/app-mobilephone/dfu-util/metadata.xml
index 6f49eba8f496..e248196b07c4 100644
--- a/app-mobilephone/dfu-util/metadata.xml
+++ b/app-mobilephone/dfu-util/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="project">
+ <email>embedded@gentoo.org</email>
+ <name>Embedded Gentoo</name>
+ </maintainer>
</pkgmetadata>