summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/obexftp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/obexftp')
-rw-r--r--app-mobilephone/obexftp/Manifest2
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.23-fix-ruby19.patch37
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.23-fixruby.patch11
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch22
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-config.patch11
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-enable_bluetooth.patch16
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-python_sitedir.patch16
-rw-r--r--app-mobilephone/obexftp/metadata.xml10
-rw-r--r--app-mobilephone/obexftp/obexftp-0.23-r2.ebuild104
-rw-r--r--app-mobilephone/obexftp/obexftp-0.24.ebuild58
10 files changed, 287 insertions, 0 deletions
diff --git a/app-mobilephone/obexftp/Manifest b/app-mobilephone/obexftp/Manifest
new file mode 100644
index 000000000000..2ad0cc4b3d96
--- /dev/null
+++ b/app-mobilephone/obexftp/Manifest
@@ -0,0 +1,2 @@
+DIST obexftp-0.23.tar.bz2 402552 SHA256 44a74ff288d38c0f75354d6bc2efe7d6dec10112eaff2e7b10e292b0d2105b36 SHA512 026a2a641fa46dc41ff131b78e87c2aa5fce126d36aa2d8b1783c7fe134a786bbf9908f660018fe459e5d729c36303f5efb2f5b2af64001a2344dce8c322e513 WHIRLPOOL d8386862c25c420ffae7089bb33b517406a6a4eecac52ad6376f3d2c5b034549e8cf86651b4ad3231b21822049b02d01863dae8776b957eb8d538c426ba4431f
+DIST obexftp-0.24-Source.tar.gz 88154 SHA256 b907965608bf0e60c69bc45f074ce1a2ffeb809b4502a7082c6d95e3c73dfe6b SHA512 785449665f5e9269d7bfd15f379bd8fbad321780292e56341e2089d6894255b7301fc23bb27a80e4e6f6317a130b658dedd307b7ece0fd31ef8f1a109c6f21b9 WHIRLPOOL 9f6fd5df3fbc8fa161ecff091b02932ac73e60d6a6eb1e15a32d9b871e6668fd86d0c4d6027f13c724cc1e7a8b40e1e02f8c0c32f0ac43076193e2048ba751df
diff --git a/app-mobilephone/obexftp/files/obexftp-0.23-fix-ruby19.patch b/app-mobilephone/obexftp/files/obexftp-0.23-fix-ruby19.patch
new file mode 100644
index 000000000000..a2ed681125cd
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.23-fix-ruby19.patch
@@ -0,0 +1,37 @@
+Replace functions removed with ruby 1.9
+See also http://dev.zuckschwerdt.org/openobex/ticket/49
+
+
+diff --git a/swig/charmap.i b/swig/charmap.i
+index e1f1fc1..b8e17de 100644
+--- a/swig/charmap.i
++++ b/swig/charmap.i
+@@ -89,8 +89,8 @@
+ $2 = PyString_Size($input);
+ #elif defined SWIGRUBY
+ /* VALUE str = StringValue($input); // perhaps better? */
+- $1 = STR2CSTR($input);
+- $2 = (int) RSTRING($input)->len;
++ $1 = StringValuePtr($input);
++ $2 = (int) RSTRING_LEN($input);
+ #elif defined SWIGTCL
+ $1 = Tcl_GetStringFromObj($input,&$2);
+ #else
+diff --git a/swig/ruby/ruby_wrap.c b/swig/ruby/ruby_wrap.c
+index 57e40bf..31b1a9d 100644
+--- a/swig/ruby/ruby_wrap.c
++++ b/swig/ruby/ruby_wrap.c
+@@ -2579,8 +2579,8 @@ _wrap_Client_put_data(int argc, VALUE *argv, VALUE self) {
+
+
+ /* VALUE str = StringValue(argv[0]); // perhaps better? */
+- arg2 = STR2CSTR(argv[0]);
+- arg3 = (int) RSTRING(argv[0])->len;
++ arg2 = StringValuePtr(argv[0]);
++ arg3 = (int) RSTRING_LEN(argv[0]);
+
+
+
+--
+1.8.4.2
+
diff --git a/app-mobilephone/obexftp/files/obexftp-0.23-fixruby.patch b/app-mobilephone/obexftp/files/obexftp-0.23-fixruby.patch
new file mode 100644
index 000000000000..c7f69ffb0d59
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.23-fixruby.patch
@@ -0,0 +1,11 @@
+--- a/swig/ruby/Makefile.am
++++ b/swig/ruby/Makefile.am
+@@ -12,7 +12,7 @@ Makefile.ruby: extconf.rb
+ PREFIX=$(prefix) $(RUBY) $< --with-obexftp-include=$(top_srcdir)
+
+ obexftp.so: ruby_wrap.c Makefile.ruby
+- $(MAKE) -fMakefile.ruby
++ $(MAKE) -fMakefile.ruby LIBPATH="-Wl,-rpath-link,../../bfb/.libs -Wl,-rpath-link,../../multicobex/.libs -Wl,-rpath-link,../../obexftp/.libs -L../../bfb/.libs -L../../multicobex/.libs -L../../obexftp/.libs"
+
+ install-data-local: Makefile.ruby
+ $(MAKE) -j1 -fMakefile.ruby install
diff --git a/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch b/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch
new file mode 100644
index 000000000000..caf0611ff071
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch
@@ -0,0 +1,22 @@
+--- a/obexftp/client.c
++++ b/obexftp/client.c
+@@ -51,8 +51,6 @@
+
+ #ifdef HAVE_BLUETOOTH
+ #include "bt_kit.h"
+-#else
+-#define ESOCKTNOSUPPORT WSAESOCKTNOSUPPORT
+ #endif /* HAVE_BLUETOOTH */
+
+ #include <openobex/obex.h>
+--- a/apps/obexftp.c
++++ b/apps/obexftp.c
+@@ -29,6 +29,8 @@
+
+ #include <sys/types.h>
+
++#include <config.h>
++
+ #ifdef HAVE_SYS_TIMES_H
+ #include <sys/times.h>
+ #endif
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-config.patch b/app-mobilephone/obexftp/files/obexftp-0.24-config.patch
new file mode 100644
index 000000000000..f923a4b0ed2c
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-config.patch
@@ -0,0 +1,11 @@
+--- a/apps/obexftp.c
++++ b/apps/obexftp.c
+@@ -43,8 +43,6 @@
+
+ #include <common.h>
+
+-#include <config.h>
+-
+ #ifdef HAVE_SYS_TIMES_H
+ #include <sys/times.h>
+ #endif
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-enable_bluetooth.patch b/app-mobilephone/obexftp/files/obexftp-0.24-enable_bluetooth.patch
new file mode 100644
index 000000000000..ff72fff17e7c
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-enable_bluetooth.patch
@@ -0,0 +1,16 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -52,11 +52,13 @@
+ #
+ # some code is only included if bluetooth is available
+ #
++if ( ENABLE_BLUETOOTH )
+ find_package ( Bluetooth )
+ if ( Bluetooth_FOUND )
+ include_directories ( ${Bluetooth_INCLUDE_DIRS} )
+ add_definitions ( -DHAVE_BLUETOOTH -DHAVE_SDP )
+ endif ( Bluetooth_FOUND )
++endif ( ENABLE_BLUETOOTH )
+
+ add_subdirectory ( bfb )
+ add_subdirectory ( multicobex )
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-python_sitedir.patch b/app-mobilephone/obexftp/files/obexftp-0.24-python_sitedir.patch
new file mode 100644
index 000000000000..24cc46050ab4
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-python_sitedir.patch
@@ -0,0 +1,16 @@
+--- a/swig/python/CMakeLists.txt
++++ b/swig/python/CMakeLists.txt
+@@ -40,11 +40,13 @@
+ OUTPUT_VARIABLE PYTHON_PREFIX
+ )
+ file ( TO_CMAKE_PATH "${PYTHON_PREFIX}" PYTHON_PREFIX )
++if ( NOT PYTHON_SITE_DIR )
+ execute_process (
+ COMMAND ${PYTHON_EXECUTABLE} -c
+ "import site, sys; sys.stdout.write(site.getsitepackages()[-1])"
+ OUTPUT_VARIABLE PYTHON_SITE_DIR
+ )
++endif ( PYTHON_SITE_DIR )
+ file ( TO_CMAKE_PATH "${PYTHON_SITE_DIR}" PYTHON_SITE_DIR )
+ string ( REGEX REPLACE "^${PYTHON_PREFIX}/" ""
+ PYTHON_SITE_DIR "${PYTHON_SITE_DIR}"
diff --git a/app-mobilephone/obexftp/metadata.xml b/app-mobilephone/obexftp/metadata.xml
new file mode 100644
index 000000000000..caf389b5674b
--- /dev/null
+++ b/app-mobilephone/obexftp/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">openobex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-mobilephone/obexftp/obexftp-0.23-r2.ebuild b/app-mobilephone/obexftp/obexftp-0.23-r2.ebuild
new file mode 100644
index 000000000000..fced95e587d6
--- /dev/null
+++ b/app-mobilephone/obexftp/obexftp-0.23-r2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+GENTOO_DEPEND_ON_PERL=no
+
+inherit distutils-r1 eutils perl-module flag-o-matic autotools
+
+DESCRIPTION="File transfer over OBEX for mobile phones"
+HOMEPAGE="http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
+SRC_URI="mirror://sourceforge/openobex/${P}.tar.bz2"
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 hppa ppc ~sparc x86"
+IUSE="bluetooth debug perl python ruby tcl"
+
+RDEPEND="dev-libs/openobex
+ bluetooth? ( net-wireless/bluez )
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-lang/ruby:1.9 )
+ tcl? ( dev-lang/tcl:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fixruby.patch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-fix-ruby19.patch
+ # Python bindings are built/installed manually.
+ sed -e "/MAYBE_PYTHON_ = python/d" -i swig/Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ if use debug ; then
+ strip-flags
+ append-flags "-g -DOBEXFTP_DEBUG=5"
+ fi
+
+ local MYRUBY
+ use ruby && MYRUBY="RUBY=/usr/bin/ruby19"
+
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcl) \
+ $(use_enable ruby) \
+ ${MYRUBY}
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd swig/python/
+ distutils-r1_src_compile
+ popd
+ fi
+}
+
+src_install() {
+ # -j1 because "make -fMakefile.ruby install" fails
+ # upstream added -j1 to that command so it should be removed
+ # from here in the next version bump
+ emake -j1 DESTDIR="${D}" INSTALLDIRS=vendor install
+
+ if use python; then
+ pushd swig/python/
+ distutils-r1_src_install
+ popd
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
+ dohtml doc/*.html
+
+ # Install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ use perl && doins examples/*.pl
+ use python && doins examples/*.py
+ use ruby && doins examples/*.rb
+ use tcl && doins examples/*.tcl
+
+ if use perl ; then
+ perl_delete_localpod
+ perl_delete_packlist
+ fi
+}
+
+pkg_postinst() {
+ use python && distutils-r1_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils-r1_pkg_postrm
+}
diff --git a/app-mobilephone/obexftp/obexftp-0.24.ebuild b/app-mobilephone/obexftp/obexftp-0.24.ebuild
new file mode 100644
index 000000000000..3a22f3409764
--- /dev/null
+++ b/app-mobilephone/obexftp/obexftp-0.24.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit cmake-utils python-single-r1 python-utils-r1 eutils multilib
+
+DESCRIPTION="File transfer over OBEX for mobile phones"
+HOMEPAGE="http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
+SRC_URI="mirror://sourceforge/openobex/${P}-Source.tar.gz"
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="bluetooth perl python ruby tcl"
+
+RDEPEND="
+ >=dev-libs/openobex-1.7
+ bluetooth? ( net-wireless/bluez )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( || ( dev-lang/ruby:2.0 dev-lang/ruby:1.9 ) )
+ tcl? ( dev-lang/tcl:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )
+ tcl? ( dev-lang/swig )
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${P}-Source
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.23-gentoo.patch
+ "${FILESDIR}"/${PN}-0.24-config.patch
+ "${FILESDIR}"/${PN}-0.24-enable_bluetooth.patch
+ "${FILESDIR}"/${PN}-0.24-python_sitedir.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PERL=$(usex perl)
+ -DENABLE_BLUETOOTH=$(usex bluetooth)
+ -DENABLE_PYTHON=$(usex python)
+ $(usex python -DPYTHON_SITE_DIR=$(python_get_sitedir) '')
+ -DENABLE_RUBY=$(usex ruby)
+ -DENABLE_TCL=$(usex tcl)
+ )
+
+ cmake-utils_src_configure
+}