summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2016-02-02 21:05:23 +0100
committerSebastian Pipping <sping@gentoo.org>2016-02-02 21:11:25 +0100
commit8324389e263b89ca2961377be72cc377a9308425 (patch)
tree42652cfccf937fe27e87d95814f697be9283d4da /app-mobilephone/wammu
parentdev-python/python-gammu: provides Python support for gammu, fixes #566168 (diff)
downloadgentoo-8324389e263b89ca2961377be72cc377a9308425.tar.gz
gentoo-8324389e263b89ca2961377be72cc377a9308425.tar.bz2
gentoo-8324389e263b89ca2961377be72cc377a9308425.zip
app-mobilephone/wammu: Adjust gammu dependency (#775)
Changelog of gammu 1.34.0 says: "Removed deprecated Python modules gammu.Data and gammu.Worker". Package-Manager: portage-2.2.27
Diffstat (limited to 'app-mobilephone/wammu')
-rw-r--r--app-mobilephone/wammu/wammu-0.35-r1.ebuild66
-rw-r--r--app-mobilephone/wammu/wammu-0.36-r1.ebuild4
2 files changed, 68 insertions, 2 deletions
diff --git a/app-mobilephone/wammu/wammu-0.35-r1.ebuild b/app-mobilephone/wammu/wammu-0.35-r1.ebuild
new file mode 100644
index 00000000000..b8d262e425f
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.35-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Front-end for gammu to access mobile phones easily"
+HOMEPAGE="http://www.wammu.eu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth gnome"
+
+RDEPEND=">=app-mobilephone/gammu-1.25.0[python] <app-mobilephone/gammu-1.34.0[python]
+ >=dev-python/wxpython-2.8
+ bluetooth? ( dev-python/pybluez
+ gnome? ( net-wireless/gnome-bluetooth )
+ )"
+DEPEND="${RDEPEND}"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv zh_CN zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ local lang support_linguas=no
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if use linguas_${lang} ; then
+ support_linguas=yes
+ break
+ fi
+ done
+ # install all languages when all selected LINGUAS aren't supported
+ if [ "${support_linguas}" = "yes" ]; then
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -r locale/${lang} || die
+ fi
+ done
+ fi
+
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ"
+ SKIPWXCHECK=yes distutils_src_install
+}
diff --git a/app-mobilephone/wammu/wammu-0.36-r1.ebuild b/app-mobilephone/wammu/wammu-0.36-r1.ebuild
index 4c84990ca76..5b974e6d201 100644
--- a/app-mobilephone/wammu/wammu-0.36-r1.ebuild
+++ b/app-mobilephone/wammu/wammu-0.36-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bluetooth gnome"
-RDEPEND=">=app-mobilephone/gammu-1.25.0[python]
+RDEPEND=">=app-mobilephone/gammu-1.25.0[python] <app-mobilephone/gammu-1.34.0[python]
>=dev-python/wxpython-2.8[${PYTHON_USEDEP}]
bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}]
gnome? ( net-wireless/gnome-bluetooth )