summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorktrace <coyote@bks.tv>2018-03-21 15:17:11 +0300
committerMichał Górny <mgorny@gentoo.org>2018-03-22 17:17:33 +0100
commita67037c9c6d144887f5a55d6749d8e3f2c568a1e (patch)
tree012da7a66d843d9c2ff1cf11d984f164d0f28f30 /app-mobilephone/wammu
parentapp-mobilephone/wammu: remove old version 0.40 (diff)
downloadgentoo-a67037c9c6d144887f5a55d6749d8e3f2c568a1e.tar.gz
gentoo-a67037c9c6d144887f5a55d6749d8e3f2c568a1e.tar.bz2
gentoo-a67037c9c6d144887f5a55d6749d8e3f2c568a1e.zip
app-mobilephone/wammu: bump version to 0.44
Closes: https://github.com/gentoo/gentoo/pull/6936 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-mobilephone/wammu')
-rw-r--r--app-mobilephone/wammu/Manifest1
-rw-r--r--app-mobilephone/wammu/wammu-0.44.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-mobilephone/wammu/Manifest b/app-mobilephone/wammu/Manifest
index 3b3e9242d766..fa5d935be9c2 100644
--- a/app-mobilephone/wammu/Manifest
+++ b/app-mobilephone/wammu/Manifest
@@ -1 +1,2 @@
DIST wammu-0.43.tar.xz 563832 BLAKE2B 26b075d16d6b26608022eac58260083b7883a3c0b0fe8b73984c625f3ecb2a6ce972cb73bc8e5ebe280726447b6fa188716206f7540a9de42013c221a05589dd SHA512 c8f0aad8d8fc2c852638a77b45d48ba3c512a1e1cf8f8dc54b99a614f7338f366494ef88d786143defd77e55ab9597d9c705569c4e0fceb856f29a05b9c6a843
+DIST wammu-0.44.tar.xz 582284 BLAKE2B ba0523d4778c0fcebc8c86354d503880ea4a34f8ba05e9c4c8ef9b206366ad11c16f85dba2ce19977587aba0bc791adade4d35422a1727b1e042d5be29f39b54 SHA512 9b1a8c9fad2abc618d3e778338446b154516fff9e176aff02ed8daa64ff6e69a591324368dacd50f40c832d16d197447c575644520102317d95c573ed8d6bc7e
diff --git a/app-mobilephone/wammu/wammu-0.44.ebuild b/app-mobilephone/wammu/wammu-0.44.ebuild
new file mode 100644
index 000000000000..9abeda111418
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.44.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Front-end for gammu to access mobile phones easily"
+HOMEPAGE="https://www.wammu.eu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth gnome"
+
+RDEPEND="
+ >=app-mobilephone/gammu-1.36
+ dev-python/python-gammu
+ >=dev-python/wxpython-2.8:*[${PYTHON_USEDEP}]
+ bluetooth? (
+ dev-python/pybluez[${PYTHON_USEDEP}]
+ gnome? ( net-wireless/gnome-bluetooth )
+ )
+"
+DEPEND="${RDEPEND}"
+
+# Required to source locale content out of the box
+DISTUTILS_IN_SOURCE_BUILD=1
+
+# SKIPWXCHECK: else 'import wx' results in
+# Xlib: connection to ":0.0" refused by server
+SKIPWXCHECK=yes