summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-02-23 20:54:44 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-02-23 20:56:23 +1100
commit274e9caad70fa9dcd8a0cf33373cb5eddba11a7c (patch)
tree1c05b6f74dade1d37db0c76b9bcf38955a98ae6a /app-mobilephone
parentdev-ros/std_msgs: Add pypy/3 support (diff)
downloadgentoo-274e9caad70fa9dcd8a0cf33373cb5eddba11a7c.tar.gz
gentoo-274e9caad70fa9dcd8a0cf33373cb5eddba11a7c.tar.bz2
gentoo-274e9caad70fa9dcd8a0cf33373cb5eddba11a7c.zip
app-mobilephone/obexftp: remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/obexftp/Manifest1
-rw-r--r--app-mobilephone/obexftp/obexftp-0.23-r2.ebuild104
2 files changed, 0 insertions, 105 deletions
diff --git a/app-mobilephone/obexftp/Manifest b/app-mobilephone/obexftp/Manifest
index 2ad0cc4b3d96..f9c337ba6b42 100644
--- a/app-mobilephone/obexftp/Manifest
+++ b/app-mobilephone/obexftp/Manifest
@@ -1,2 +1 @@
-DIST obexftp-0.23.tar.bz2 402552 SHA256 44a74ff288d38c0f75354d6bc2efe7d6dec10112eaff2e7b10e292b0d2105b36 SHA512 026a2a641fa46dc41ff131b78e87c2aa5fce126d36aa2d8b1783c7fe134a786bbf9908f660018fe459e5d729c36303f5efb2f5b2af64001a2344dce8c322e513 WHIRLPOOL d8386862c25c420ffae7089bb33b517406a6a4eecac52ad6376f3d2c5b034549e8cf86651b4ad3231b21822049b02d01863dae8776b957eb8d538c426ba4431f
DIST obexftp-0.24-Source.tar.gz 88154 SHA256 b907965608bf0e60c69bc45f074ce1a2ffeb809b4502a7082c6d95e3c73dfe6b SHA512 785449665f5e9269d7bfd15f379bd8fbad321780292e56341e2089d6894255b7301fc23bb27a80e4e6f6317a130b658dedd307b7ece0fd31ef8f1a109c6f21b9 WHIRLPOOL 9f6fd5df3fbc8fa161ecff091b02932ac73e60d6a6eb1e15a32d9b871e6668fd86d0c4d6027f13c724cc1e7a8b40e1e02f8c0c32f0ac43076193e2048ba751df
diff --git a/app-mobilephone/obexftp/obexftp-0.23-r2.ebuild b/app-mobilephone/obexftp/obexftp-0.23-r2.ebuild
deleted file mode 100644
index fced95e587d6..000000000000
--- a/app-mobilephone/obexftp/obexftp-0.23-r2.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 )
-GENTOO_DEPEND_ON_PERL=no
-
-inherit distutils-r1 eutils perl-module flag-o-matic autotools
-
-DESCRIPTION="File transfer over OBEX for mobile phones"
-HOMEPAGE="http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
-SRC_URI="mirror://sourceforge/openobex/${P}.tar.bz2"
-SLOT="0"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 hppa ppc ~sparc x86"
-IUSE="bluetooth debug perl python ruby tcl"
-
-RDEPEND="dev-libs/openobex
- bluetooth? ( net-wireless/bluez )
- perl? ( dev-lang/perl:= )
- ruby? ( dev-lang/ruby:1.9 )
- tcl? ( dev-lang/tcl:0= )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-fixruby.patch \
- "${FILESDIR}"/${P}-gentoo.patch \
- "${FILESDIR}"/${P}-fix-ruby19.patch
- # Python bindings are built/installed manually.
- sed -e "/MAYBE_PYTHON_ = python/d" -i swig/Makefile.am || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- if use debug ; then
- strip-flags
- append-flags "-g -DOBEXFTP_DEBUG=5"
- fi
-
- local MYRUBY
- use ruby && MYRUBY="RUBY=/usr/bin/ruby19"
-
- econf \
- $(use_enable bluetooth) \
- $(use_enable perl) \
- $(use_enable python) \
- $(use_enable tcl) \
- $(use_enable ruby) \
- ${MYRUBY}
-}
-
-src_compile() {
- default
-
- if use python; then
- pushd swig/python/
- distutils-r1_src_compile
- popd
- fi
-}
-
-src_install() {
- # -j1 because "make -fMakefile.ruby install" fails
- # upstream added -j1 to that command so it should be removed
- # from here in the next version bump
- emake -j1 DESTDIR="${D}" INSTALLDIRS=vendor install
-
- if use python; then
- pushd swig/python/
- distutils-r1_src_install
- popd
- fi
-
- dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
- dohtml doc/*.html
-
- # Install examples
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.c
- use perl && doins examples/*.pl
- use python && doins examples/*.py
- use ruby && doins examples/*.rb
- use tcl && doins examples/*.tcl
-
- if use perl ; then
- perl_delete_localpod
- perl_delete_packlist
- fi
-}
-
-pkg_postinst() {
- use python && distutils-r1_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils-r1_pkg_postrm
-}