summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 11:56:16 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 12:42:43 +0200
commit29f814d41ac74fecc625718185a27f89b60f7fce (patch)
treebfcfab4bdaac24261fd40f8014d8761c8c56eb4f /app-office/gnucash
parentapp-editors/ghex: Version bump (diff)
downloadgentoo-29f814d41ac74fecc625718185a27f89b60f7fce.tar.gz
gentoo-29f814d41ac74fecc625718185a27f89b60f7fce.tar.bz2
gentoo-29f814d41ac74fecc625718185a27f89b60f7fce.zip
app-office/gnucash: Drop old
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-office/gnucash')
-rw-r--r--app-office/gnucash/Manifest1
-rw-r--r--app-office/gnucash/files/gnucash-2.6.9-automagic-guile.patch88
-rw-r--r--app-office/gnucash/gnucash-2.6.11.ebuild114
3 files changed, 0 insertions, 203 deletions
diff --git a/app-office/gnucash/Manifest b/app-office/gnucash/Manifest
index 4c13ee7261a..122d9011838 100644
--- a/app-office/gnucash/Manifest
+++ b/app-office/gnucash/Manifest
@@ -1,2 +1 @@
-DIST gnucash-2.6.11.tar.bz2 13626927 SHA256 516d97afa61971ca0a16f56319f3f7129db2da1a9d2c77ab7d8b4e6e9e018ac6 SHA512 f3708018f85d17377e11ce55452be7cedd6041da12f66e00047e3cdafb0190da850eb4cbb5699f01cbd79c540af7ef75b44b93c2d5929e13c2a47484741e6a7e WHIRLPOOL 3a5d78835a89718ee539a4c8a62e963172f2e41b8ce1c01ead2425f24529edc8ebc76f41f84596bf8f1438c81e687cc13ed2a4cbd72e87ca35725d88fcdf7d7f
DIST gnucash-2.6.12.tar.bz2 13549926 SHA256 371fe9af3ec4b5d6839722b07c9064a51cfe247511edaa6286fc82710f700475 SHA512 3abf6f27413e087b2d4242772cdae87c9f13c1c952ccc0b79cb262baa0c076ee4fe227458346ece3967d1e1158aa38db3ec5dfb20db27050e4580e7762854993 WHIRLPOOL fd6a0c66e394e1e80fe95630dae930c86d05e18aa89b298d862089802438080ac1997d9edb1d159868efd664f839158edc4eeb99e6484cbb142ca97b6ac94a9d
diff --git a/app-office/gnucash/files/gnucash-2.6.9-automagic-guile.patch b/app-office/gnucash/files/gnucash-2.6.9-automagic-guile.patch
deleted file mode 100644
index a871233ecd7..00000000000
--- a/app-office/gnucash/files/gnucash-2.6.9-automagic-guile.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From a42d0a1d9e3311a5e2356676fef7843f1726d343 Mon Sep 17 00:00:00 2001
-From: Gilles Dartiguelongue <eva@gentoo.org>
-Date: Wed, 11 Nov 2015 13:35:46 +0100
-Subject: [PATCH] Make guile support selectable
-
----
- configure.ac | 55 +++++++++++++++++++++++++++++++++++++------------------
- 1 file changed, 37 insertions(+), 18 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 48ab828..ce7ba74 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -538,26 +538,45 @@ AC_CHECK_FUNCS(gethostid link)
- ### --------------------------------------------------------------------------
- ### Guile version checks
-
-+GUILE_EFFECTIVE_VERSION=0
- # - check minimum version
- # - determine GUILE_CFLAGS and GUILE_LIBS
--gnc_have_guile_2=no
--gnc_have_guile_www=no
--PKG_CHECK_MODULES(GUILE,
-- [guile-2.0 >= 2.0.0],
-- [gnc_have_guile_2=yes
-- GUILE_EFFECTIVE_VERSION=2.0
-- AC_PATH_PROG([GUILD], guild)],
-- [PKG_CHECK_MODULES(GUILE,
-- [guile-1.8 >= 1.8.5],
-- [GUILE_EFFECTIVE_VERSION=1.8],
-- [AC_MSG_ERROR([
-- guile does not appear to be installed correctly, or is not in the
-- correct version range. Perhaps you have not installed the guile
-- development packages? Gnucash requires at least version 1.8.5 to build.
-- ])])
--])
-
--AM_CONDITIONAL(GNC_HAVE_GUILE_2, test "x${gnc_have_guile_2}" = xyes)
-+AC_ARG_WITH([guile],
-+ AS_HELP_STRING([--with-guile=1.8|2.0|auto],
-+ [which guile version to compile against @<:@default: auto@:>@]),
-+ [],
-+ [with_guile=auto]
-+)
-+
-+AS_IF([test "$with_guile" = "2.0"],
-+ [PKG_CHECK_MODULES(GUILE, [guile-2.0 >= 2.0.0],
-+ [GUILE_EFFECTIVE_VERSION=2.0
-+ AC_PATH_PROG([GUILD], guild)])],
-+ [test "$with_guile" = "1.8"],
-+ [PKG_CHECK_MODULES(GUILE, [guile-1.8 >= 1.8.5],
-+ [GUILE_EFFECTIVE_VERSION=1.8])],
-+ [test "$with_guile" = "auto"],
-+ [PKG_CHECK_MODULES(GUILE, [guile-2.0 >= 2.0.0],
-+ [GUILE_EFFECTIVE_VERSION=2.0
-+ AC_PATH_PROG([GUILD], guild)],
-+ [PKG_CHECK_MODULES(GUILE, [guile-1.8 >= 1.8.5],
-+ [GUILE_EFFECTIVE_VERSION=1.8],
-+ [GUILE_EFFECTIVE_VERSION=0])
-+ ])],
-+ # else
-+ [AC_MSG_ERROR([invalid guile version specified])]
-+)
-+
-+AS_IF([test "$GUILE_EFFECTIVE_VERSION" = "0"],
-+ [AC_MSG_ERROR([
-+ guile does not appear to be installed correctly, or is not in the
-+ correct version range. Perhaps you have not installed the guile
-+ development packages? Gnucash requires at least version 1.8.5 to build.
-+ ])]
-+)
-+
-+AM_CONDITIONAL(GNC_HAVE_GUILE_2, [test "$GUILE_EFFECTIVE_VERSION" = "2.0"])
- AC_SUBST(GUILE_EFFECTIVE_VERSION)
- AC_SUBST(GUILE, [`pwd`/gnc-guile])
-
-@@ -584,7 +603,7 @@ if test "${BUILDING_FROM_VCS}" = yes
- then
- AX_PKG_SWIG(2.0.10, [gnc_have_swig_2_0_10=yes], [gnc_have_swig_2_0_10=no])
-
-- if test "${gnc_have_guile_2}" = yes
-+ if test "${GUILE_EFFECTIVE_VERSION}" = "2.0"
- then
- if test "${gnc_have_swig_2_0_10}" = no
- then
---
-2.6.3
-
diff --git a/app-office/gnucash/gnucash-2.6.11.ebuild b/app-office/gnucash/gnucash-2.6.11.ebuild
deleted file mode 100644
index 08fbbe29fde..00000000000
--- a/app-office/gnucash/gnucash-2.6.11.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools eutils gnome2 python-single-r1
-
-DESCRIPTION="A personal finance manager"
-HOMEPAGE="http://www.gnucash.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="chipcard debug +doc gnome-keyring hbci mysql ofx postgres python quotes sqlite"
-
-# FIXME: rdepend on dev-libs/qof when upstream fix their mess (see configure.ac)
-# libdbi version requirement for sqlite taken from bug #455134
-RDEPEND="
- >=dev-libs/glib-2.32.0:2
- >=dev-libs/popt-1.5
- >=dev-libs/libxml2-2.5.10:2
- dev-libs/libxslt
- >=dev-scheme/guile-1.8.3:12[deprecated,regex]
- dev-scheme/guile-www
- gnome-base/libgnomecanvas
- >=net-libs/webkit-gtk-1.2:2
- >=sys-libs/zlib-1.1.4
- >=x11-libs/gtk+-2.24:2
- >=x11-libs/goffice-0.7.0:0.8[gnome]
- x11-libs/pango
- gnome-keyring? ( >=app-crypt/libsecret-0.18 )
- ofx? ( >=dev-libs/libofx-0.9.1 )
- hbci? ( >=net-libs/aqbanking-5[gtk,ofx?]
- sys-libs/gwenhywfar[gtk]
- chipcard? ( sys-libs/libchipcard )
- )
- python? ( ${PYTHON_DEPS} )
- quotes? ( dev-perl/Date-Manip
- >=dev-perl/Finance-Quote-1.11
- dev-perl/HTML-TableExtract )
- sqlite? ( >=dev-db/libdbi-0.9.0
- >=dev-db/libdbi-drivers-0.9.0[sqlite] )
- postgres? ( dev-db/libdbi dev-db/libdbi-drivers[postgres] )
- mysql? ( dev-db/libdbi dev-db/libdbi-drivers[mysql] )
-"
-DEPEND="${RDEPEND}
- dev-util/intltool
- gnome-base/gnome-common
- sys-devel/libtool
- virtual/pkgconfig
-"
-PDEPEND="doc? ( >=app-doc/gnucash-docs-2.2.0 )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # Skip test that needs some locales to be present
- sed -i -e '/test_suite_gnc_date/d' src/libqof/qof/test/test-qof.c || die
-
- # Fix automagic on guile detection
- # https://bugzilla.gnome.org/show_bug.cgi?id=760015
- epatch "${FILESDIR}"/${PN}-2.6.9-automagic-guile.patch
-
- eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- local myconf
-
- DOCS="doc/README.OFX doc/README.HBCI"
-
- if use sqlite || use mysql || use postgres ; then
- myconf+=" --enable-dbi"
- else
- myconf+=" --disable-dbi"
- fi
-
- # gtkmm is experimental and shouldn't be enabled, upstream bug #684166
- gnome2_src_configure \
- $(use_enable debug) \
- $(use_enable gnome-keyring password-storage) \
- $(use_enable ofx) \
- $(use_enable hbci aqbanking) \
- $(use_enable python) \
- --with-guile=1.8 \
- --disable-doxygen \
- --disable-gtkmm \
- --enable-locale-specific-tax \
- --disable-error-on-warning \
- ${myconf}
-}
-
-src_test() {
- GUILE_WARN_DEPRECATED=no \
- GNC_DOT_DIR="${T}"/.gnucash \
- emake check
-}
-
-src_install() {
- # Parallel installation fails from time to time, bug #359123
- MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install GNC_DOC_INSTALL_DIR=/usr/share/doc/${PF}
-
- rm -rf "${ED}"/usr/share/doc/${PF}/{examples/,COPYING,INSTALL,*win32-bin.txt,projects.html}
- mv "${ED}"/usr/share/doc/${PF} "${T}"/cantuseprepalldocs || die
- dodoc "${T}"/cantuseprepalldocs/*
-}