summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-12 04:02:54 +0100
committerSam James <sam@gentoo.org>2022-07-12 04:03:22 +0100
commit9f9473c1a4a28522371b99d0a36665c18c1f8ec5 (patch)
tree6181b71cc05bb977cc6f14d871342e0b7fd7d910 /app-office/gtg
parentdev-python/caldav: new package, add 0.9.1 (diff)
downloadgentoo-9f9473c1a4a28522371b99d0a36665c18c1f8ec5.tar.gz
gentoo-9f9473c1a4a28522371b99d0a36665c18c1f8ec5.tar.bz2
gentoo-9f9473c1a4a28522371b99d0a36665c18c1f8ec5.zip
app-office/gtg: add missing dependencies, fix tests
See: https://github.com/gentoo/gentoo/pull/26269 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office/gtg')
-rw-r--r--app-office/gtg/gtg-0.6.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/app-office/gtg/gtg-0.6.ebuild b/app-office/gtg/gtg-0.6.ebuild
index 7fe456bf3945..d4d376aab05b 100644
--- a/app-office/gtg/gtg-0.6.ebuild
+++ b/app-office/gtg/gtg-0.6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml(+)"
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/getting-things-gnome/gtg/archive/refs/tags/v${PV}.ta
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
IUSE="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
@@ -21,11 +21,14 @@ RESTRICT="!test? ( test )"
RDEPEND="
${PYTHON_DEPS}
$(python_gen_cond_dep '
+ dev-python/caldav[${PYTHON_USEDEP}]
dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
>=dev-python/liblarch-3.1.0[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
')
x11-libs/pango[introspection]
x11-libs/gdk-pixbuf[introspection]
@@ -36,9 +39,9 @@ BDEPEND="
dev-util/itstool
>=sys-devel/gettext-0.19.8
test? ( $(python_gen_cond_dep '
- dev-python/nose[${PYTHON_USEDEP}]
dev-python/cheetah3[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
')
|| ( app-text/pdfjam >=app-text/texlive-core-2021 )
app-text/pdftk
@@ -48,7 +51,7 @@ BDEPEND="
src_test() {
sed -e "s|@VCS_TAG@|${PV}|" GTG/core/info.py.in > GTG/core/info.py || die
- nosetests -v || die
+ epytest
}
src_install() {