summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-08 18:34:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-08 18:51:32 +0200
commit54a413761897ba5ca5be71fc8ea0b20e0d0dd4da (patch)
tree150cb966d4c7ba241b5481608d2ed2a0c27eb2e4 /app-office/libreoffice/libreoffice-9999.ebuild
parentapp-office/libreoffice: Java baseline was raised to 1.8 (diff)
downloadgentoo-54a413761897ba5ca5be71fc8ea0b20e0d0dd4da.tar.gz
gentoo-54a413761897ba5ca5be71fc8ea0b20e0d0dd4da.tar.bz2
gentoo-54a413761897ba5ca5be71fc8ea0b20e0d0dd4da.zip
app-office/libreoffice: Update USE !java and add USE !firebird notice
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/libreoffice/libreoffice-9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 52c32f853b5..f0ca704cc85 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -265,8 +265,11 @@ _check_reqs() {
}
pkg_pretend() {
- use java || \
- ewarn "If you plan to use Base application you should enable java or you will get various crashes."
+ if ! use java && ! use firebird; then
+ ewarn "If you plan to use Base application you must enable either firebird or java."
+ fi
+
+ use java || ewarn "Without java, several wizards are not going to be available."
if has_version "<app-office/libreoffice-5.3.0[firebird]"; then
ewarn "Firebird has been upgraded to version 3. It is unable to read back Firebird 2.5 data, so"