summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-01-03 08:23:37 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2020-01-03 08:24:00 +0100
commit91e7091096936ef82d8ea76edc8b595a4d4f7d92 (patch)
tree9e7ac6228caa81612a14b0d656cb4f27ebb99e0a /app-office
parentdev-ruby/tokyocabinet: add ruby27 (diff)
downloadgentoo-91e7091096936ef82d8ea76edc8b595a4d4f7d92.tar.gz
gentoo-91e7091096936ef82d8ea76edc8b595a4d4f7d92.tar.bz2
gentoo-91e7091096936ef82d8ea76edc8b595a4d4f7d92.zip
app-office/scribus: fixed 9999
1) added python3_8 2) switched from cmake-utils to cmake 3) removed unused config args Bug: https://bugs.gentoo.org/691684 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/scribus/scribus-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/app-office/scribus/scribus-9999.ebuild b/app-office/scribus/scribus-9999.ebuild
index ac7b913c7f8e..da3a47d25206 100644
--- a/app-office/scribus/scribus-9999.ebuild
+++ b/app-office/scribus/scribus-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="tk?"
-inherit cmake-utils desktop flag-o-matic python-single-r1 subversion xdg
+inherit cmake desktop flag-o-matic python-single-r1 subversion xdg
DESCRIPTION="Desktop publishing (DTP) and layout program"
HOMEPAGE="https://www.scribus.net/"
@@ -77,7 +77,8 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ default
+ _CMAKE_SRC_PREPARE_HAS_RUN=1
rm -r codegen/cheetah scribus/third_party/hyphen || die
@@ -109,8 +110,6 @@ src_configure() {
local mycmakeargs=(
-DHAVE_PYTHON=ON
- -DPYTHON_INCLUDE_PATH=$(python_get_includedir)
- -DPYTHON_LIBRARY=$(python_get_library_path)
-DWANT_DISTROBUILD=ON
-DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}/
-DWITH_BOOST=$(usex boost)
@@ -123,11 +122,11 @@ src_configure() {
-DWITH_PODOFO=$(usex pdf)
-DWANT_NOTEMPLATES=$(usex !templates)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if ! use tk; then
rm "${ED}"/usr/share/scribus/scripts/{FontSample,CalendarWizard}.py || die