summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2020-06-03 19:20:35 +0200
committerJonas Stein <jstein@gentoo.org>2020-06-03 19:21:09 +0200
commitf1de944105f04f686590e858a8b47644ca32f8ed (patch)
treeaf45027d3e1699cf937a03910ec3e26d610a87dc /app-office
parentdev-python/ujson: 3.0.0 (diff)
downloadgentoo-f1de944105f04f686590e858a8b47644ca32f8ed.tar.gz
gentoo-f1de944105f04f686590e858a8b47644ca32f8ed.tar.bz2
gentoo-f1de944105f04f686590e858a8b47644ca32f8ed.zip
app-office/texstudio: Version bump to 3.0.0_pre20200601
This is a prerelease of TeXStudio 3.0.0. Upstream also known as alpha 6. It includes fixes for the following bugs Bug: https://bugs.gentoo.org/709464 Bug: https://bugs.gentoo.org/719132 Bug: https://bugs.gentoo.org/719132 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texstudio/Manifest1
-rw-r--r--app-office/texstudio/texstudio-3.0.0_pre20200601.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/app-office/texstudio/Manifest b/app-office/texstudio/Manifest
index 5c0c64a5f4b0..ca6453a923d4 100644
--- a/app-office/texstudio/Manifest
+++ b/app-office/texstudio/Manifest
@@ -1,2 +1,3 @@
DIST texstudio-2.12.16.tar.gz 34528802 BLAKE2B acf13d8bcd9a2017f19ab4484f6eab3f41868bcbbe364d869466d971b10f602652145be4082f1cef6a6d3be91c51d7bfa35e992b00cca0748f2178ddf36a263c SHA512 0c17fda78e0cd491d2869ccb1a164ae2348281a39f9883d813ceb2ed6a0287c4cf9e784cafb9c0a12b8839d7afc8897f8f74acffd87a5dfcb50d3b344f33ad28
DIST texstudio-2.12.22.tar.gz 35965795 BLAKE2B 28d78e4c429d306e86abf54701395bcc6457c51f3264094f9d5737082161bf157d248f7913bda4eec8319632c4b2c38e8a3d4916c902cc3b86cd91b64c0238d9 SHA512 c589285d1fba00812583a3d58602a99e044eb4bcf6a84b939d00ad7fe4ba8f15788031361fc9b4cb8df19f8098911c437d1de5459c1736fa40888b88d13b10d1
+DIST texstudio-3.0.0_pre20200601.tar.gz 35982392 BLAKE2B 1eed56fe21aac141df41f251621a902a20153b0eaafc995b56fa8c3fbcc213685710e45202fbb90a071a0efac591c86588d4c5fe3727e603e0a58e149ed6864e SHA512 d922f576055fc345e7e0125074c6dbb473c6fb95aa06ae1ffc15f3b89fbdc7c5a44a13d4a32b770bef10c7bae7211a4bf3a269996eda1b3a0c8fd1ed8f3c4bb1
diff --git a/app-office/texstudio/texstudio-3.0.0_pre20200601.ebuild b/app-office/texstudio/texstudio-3.0.0_pre20200601.ebuild
new file mode 100644
index 000000000000..549dc6356a4c
--- /dev/null
+++ b/app-office/texstudio/texstudio-3.0.0_pre20200601.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit prefix qmake-utils xdg-utils desktop
+
+MY_PV="3.0.0alpha6"
+
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="https://www.texstudio.org https://github.com/texstudio-org/texstudio"
+SRC_URI="https://github.com/texstudio-org/texstudio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="video"
+
+COMMON_DEPEND="
+ app-text/hunspell:=
+ app-text/poppler[qt5]
+ >=dev-libs/quazip-0.7.2[qt5(+)]
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsvg:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ video? ( media-libs/phonon[qt5(+)] )"
+RDEPEND="${COMMON_DEPEND}
+ app-text/ghostscript-gpl
+ app-text/psutils
+ media-libs/netpbm
+ virtual/latex-base"
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ default
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed \
+ -e '/qtsingleapplication.pri/d' \
+ -i ${PN}.pro || die
+
+ cp "${FILESDIR}"/texmakerx_my.pri ${PN}.pri || die
+ eprefixify ${PN}.pri
+}
+
+src_configure() {
+ eqmake5 USE_SYSTEM_HUNSPELL=1 USE_SYSTEM_QUAZIP=1
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64 128x128; do
+ newicon -s ${i} utilities/${PN}${i}.png ${PN}.png
+ done
+ emake DESTDIR="${D}" INSTALL_ROOT="${ED}" install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}