summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/barry
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/barry')
-rw-r--r--app-pda/barry/Manifest1
-rw-r--r--app-pda/barry/barry-0.18.3.ebuild112
-rw-r--r--app-pda/barry/metadata.xml22
3 files changed, 135 insertions, 0 deletions
diff --git a/app-pda/barry/Manifest b/app-pda/barry/Manifest
new file mode 100644
index 000000000000..04d6bb81ecda
--- /dev/null
+++ b/app-pda/barry/Manifest
@@ -0,0 +1 @@
+DIST barry-0.18.3.tar.bz2 3457451 SHA256 c9dc6d1790d00f5535bbc0777082cd303aa8ca2e4256f1b16cafda44be97ce2c SHA512 4944d22bd5f5a76201ca10ccaf9d12ecf21b298e5b9c8d3d503441e0ad0386a94699c48ae683004992508bb385e75ec137859509663148f2f148933fa508e7fd WHIRLPOOL c991b1239d8f4c40c7e61fb4af1e6dbadb9e47c793a8e232556b8a2d8d08ca7474607e5c2ac3a557d1aad007d3ff7a1f74041351813e7ff77a131dfaeeb95999
diff --git a/app-pda/barry/barry-0.18.3.ebuild b/app-pda/barry/barry-0.18.3.ebuild
new file mode 100644
index 000000000000..7fcd3964340c
--- /dev/null
+++ b/app-pda/barry/barry-0.18.3.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit bash-completion-r1 eutils gnome2-utils udev
+
+DESCRIPTION="Sync, backup, program management, and charging for BlackBerry devices"
+HOMEPAGE="http://www.netdirect.ca/software/packages/barry/"
+SRC_URI="mirror://sourceforge/barry/${P}.tar.bz2"
+
+LICENSE="CC-BY-SA-3.0 GPL-2" #See logo/README for CCPL
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost desktop doc gui opensync nls static-libs"
+
+RDEPEND=">=dev-cpp/libxmlpp-2.6
+ >=dev-libs/glib-2
+ >=dev-libs/libtar-1.2.11-r2
+ >=media-libs/libsdl-1.2
+ >=sys-fs/fuse-2.5
+ sys-libs/zlib
+ virtual/libusb:1
+ boost? ( >=dev-libs/boost-1.33 )
+ desktop? ( >=net-libs/libgcal-0.9.6 )
+ gui? (
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-cpp/libglademm:2.4
+ )
+ opensync? ( ~app-pda/libopensync-0.22 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=app-doc/doxygen-1.5.6 )
+ nls? ( >=sys-devel/gettext-0.18.1.1 )"
+
+DOCS=( AUTHORS ChangeLog KnownBugs NEWS README TODO )
+
+src_prepare() {
+ sed -i -e 's:plugdev:usb:g' "${S}"/udev/99-blackberry-perms.rules || die
+ sed -i -e '/Icon/s:=.*:=barry:' "${S}"/menu/*.desktop || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable boost) \
+ $(use_enable gui) \
+ $(use_enable opensync opensync-plugin) \
+ $(use_enable desktop) \
+ --disable-rpath
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ cd "${S}"
+ doxygen || die
+ fi
+}
+
+src_install() {
+ default
+
+ # docs
+ rm -rf "${S}"/doc/www/*.{php,sh}
+ find "${S}"/doc/www/doxygen/html -name "*.map" -size 0 -exec rm -f {} +
+ use doc && dohtml "${S}"/doc/www/doxygen/html/*
+ rm -rf "${S}"/doc/www
+ dodoc -r "${S}"/doc/*
+
+ # Skipping different (old Fedora) rules 69-blackberry.rules in purpose
+ udev_dorules "${S}"/udev/10-blackberry.rules "${S}"/udev/99-blackberry-perms.rules
+
+ # blacklist for BERRY_CHARGE kernel module
+ insinto /lib/modprobe.d
+ doins "${S}"/modprobe/blacklist-berry_charge.conf
+
+ # pppd options files
+ docinto ppp
+ dodoc "${S}"/ppp/*
+
+ dobashcomp "${S}"/bash/btool "${S}"/bash/bjavaloader
+
+ newicon -s scalable "${S}"/logo/${PN}_logo_icon.svg ${PN}.svg
+ use desktop && domenu "${S}"/menu/barrydesktop.desktop
+ use gui && domenu "${S}"/menu/barrybackup.desktop
+
+ prune_libtool_files
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "Barry requires you to be a member of the \"usb\" group."
+ ewarn
+ ewarn "Barry and the in-kernel module 'BERRY_CHARGE' are incompatible."
+ ewarn
+ ewarn "Kernel-based USB suspending can discharge your blackberry."
+ ewarn "Use at least kernel 2.6.22 and/or disable CONFIG_USB_SUSPEND."
+ ewarn
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-pda/barry/metadata.xml b/app-pda/barry/metadata.xml
new file mode 100644
index 000000000000..2ac61ee9e44a
--- /dev/null
+++ b/app-pda/barry/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rhill@gentoo.org</email>
+ <name>Ryan Hill</name>
+ </maintainer>
+ <herd>pda</herd>
+ <longdescription lang="en">
+ Barry is a utility for synchronization, backup, restore,
+ program management, and charging of BlackBerry devices.
+ </longdescription>
+ <use>
+ <flag name="boost">Enable boost support</flag>
+ <flag name="desktop">Install the GUI desktop control panel</flag>
+ <flag name="gui">Install the GUI backup tool</flag>
+ <flag name="opensync">Install the barry-sync plugin for OpenSync 0.22</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">barry</remote-id>
+ </upstream>
+</pkgmetadata>