summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/usbmuxd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/usbmuxd')
-rw-r--r--app-pda/usbmuxd/Manifest1
-rw-r--r--app-pda/usbmuxd/metadata.xml5
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild34
3 files changed, 40 insertions, 0 deletions
diff --git a/app-pda/usbmuxd/Manifest b/app-pda/usbmuxd/Manifest
new file mode 100644
index 000000000000..070189d6674c
--- /dev/null
+++ b/app-pda/usbmuxd/Manifest
@@ -0,0 +1 @@
+DIST usbmuxd-1.0.8_p20140530.tar.xz 46988 SHA256 de5947571d8a2dc15da41ab6d916f11ff008365a127f965cd397e6309e9200dc SHA512 200c9bd208ef9e8d5e0a9b2779ff260efe6319333ce27c93a0686ba924e6cfaa1a003072c3eabbe46d495a66bc47c3cd6e82482653fde5e1a7ae0edd9b838fac WHIRLPOOL dce14308373921e0f396776b55c9985d83e84a1832d0e54b0058ac9ef9148c2008a004df8574ac455de367af4d0dcc8211f1a8960ef0d8f96eefe6b192b5bf5c
diff --git a/app-pda/usbmuxd/metadata.xml b/app-pda/usbmuxd/metadata.xml
new file mode 100644
index 000000000000..228404d3a4b2
--- /dev/null
+++ b/app-pda/usbmuxd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pda</herd>
+</pkgmetadata>
diff --git a/app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild b/app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild
new file mode 100644
index 000000000000..8ecee6def04c
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils udev user
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+#SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="GPL-2 GPL-3 LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-pda/libimobiledevice-1.1.6
+ >=app-pda/libplist-1.11
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ virtual/pkgconfig"
+
+pkg_setup() {
+ enewgroup plugdev
+ enewuser usbmux -1 -1 -1 "usb,plugdev"
+}
+
+src_install() {
+ autotools-utils_src_install udevrulesdir="$(get_udevdir)"/rules.d
+}